cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ashwnaidv100
Helper III
Helper III

Gallery Items text not Visible.

Hi, Currently I'm using Gallery view to select buttons. And my button are just an items for that Gallery, My Gallery filters based on certain conditions (Shared the Item logic within screenshot). But Not sure Why my Items Text not coming within the button text and even for separated Label component used. 

 

As you can see my Title1 is not showing up and even not showing in the buttons (within Gallery).

 

powerapp issue.PNG

 

Here's my Gallery Items logic , Currently I'm using Switch condition and its working fine, even with If conditions its also working good, but not sure why my Text names not showing up, even the number of items showing in gallery are correct with switching to other data sources. My Data Sources contains only one column with the column name being same matching values for Switch condition. 

 

powerapp issue1.PNG

 

I'm hoping you got the clear picture on my issues. Any hint and guesses to resolve this would be really helpful. 

Not sure if I'm thinking straight. 

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @WarrenBelz et al,

 

I was able to figure it out the Issue. 

 

It was just to copy - paste the same code on some place. I have paste on my same code (shared in previous reply) in Gallery1 on OnSelect property and in Gallery2 on Items property and same on the Button Text in Gallery2. And its working like a charm 😀.

 

Thanks for all the support and efforts. 

View solution in original post

9 REPLIES 9
WarrenBelz
Super User
Super User

Hi @ashwnaidv100 ,

What is GalleryNavigation_9.Selected.Label2_9.Text, and where have you put that formula?

ashwnaidv100_0-1598418066186.png

Ticked marked is my gallery (Where I'm selecting GalleryNavigation_9.Selected.Label2_9.Text ). I'm using my GalleryNavigation_9  to select item to filter my current Gallery. This formula is putted on Gallery Items with buttons which I'm filtering. 

Hi @ashwnaidv100 ,

You mentioned a component - is this item one of those?

Hi @WarrenBelz ,

Apologies for writing component.  I just wanted to say Tick marked.

 

ashwnaidv100_0-1598423183010.png

The Gallery1 is GalleryNavigation_9 and Gallery2 is where I have putted my Switch condition logic in Items.  And those items not showing their associated Text values.

Hi @ashwnaidv100 ,

I just did a test this end with the exact syntax and got the correct values on a label for each selection. If you put

 GalleryNavigation_9.Selected.Label2_9.Text

on a label, do you receive the expected value? 

Thanks @WarrenBelz , 

 

Tried but it not worked. I think my post didn't clear enough to make sense. 

Let me try to re-explain it here.

 

This is my expected output.  

 

ashwnaidv100_0-1598432290727.png    

 

 

This Collection I need to pass to my Gallery2.

ashwnaidv100_1-1598433968775.png

 

 

( Refer image from previous reply for Gallery1 and Gallery2 )

 

1. I have 2 Table, Table1 and Table2

2. Where Table1 contains items in Gallery1 (which is also called GalleryNavigation_9) , Such as ["Personal details", "General authoring software"].

3. Table 2 contains a list of software's that I need to show within a Gallery2, As you can see the expected result, It working file for Connecting my Table2 directly. But instead of that I have used collections (orange marked texts below). 

4. Below orange marked texts are my passed collections to Gallery2 when condition true. 

 

Switch(GalleryNavigation_9.Selected.Label2_9.Text"General Authoring Software"generalauthoringsoftware"Sector Specific Software"builtenvironmentsoftware)

 

Hope this will help you to make more realistic test case close to this issue. 

To Create sample test case for this, then just try these steps.

 

1. Create a gallery and and try to Switch the data source based on certain inputs either by dropdown or anything else. 

2. and try to put the Items Text in Gallery. 

 

 

@ashwnaidv100 ,

I cannot get my mind around this one sorry - I will tag one of my colleagues @mdevaney to see if he can do better.

Hi @WarrenBelz et al,

 

I was able to figure it out the Issue. 

 

It was just to copy - paste the same code on some place. I have paste on my same code (shared in previous reply) in Gallery1 on OnSelect property and in Gallery2 on Items property and same on the Button Text in Gallery2. And its working like a charm 😀.

 

Thanks for all the support and efforts. 

View solution in original post

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,299)