cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
HISD_JSO
Frequent Visitor

Gallery Navigation button not working.

Hello,

 

I am having an issue with a canvas app I put together. It uses a gallery that is extended to show only one record at a time. Whenever the app is loaded the "Navigate Forward" button does not respond. It works as expected on the studio but when loaded on the player the button it animates on click but the gallery does not navigate forward.

After much frustating experimentation I have determined that using the scroll bar first then the navigation button fixes the issue for that session, however it is not something I can ask my users to do everytime.

Any help would be appreciated.


13 REPLIES 13
Community Support
Community Support

Re: Gallery Navigation button not working.

Hi @HISD_JSO ,

Could you show me your formula about Navigate?

I've made a similar test but not met the sam problem like your description.

I could navigate to another screen by click the Navigate button in Play mode.

Here's the formula that I use:

Navigate(Screen2,None)

What's more, I set it to one button's OnSelect property.

 

 

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
HISD_JSO
Frequent Visitor

Re: Gallery Navigation button not working.

Hello!

 

Sorry, let me clarify clarify It is not a navigation button as in "A button control I created that use the navigate function to navigate to another screen". It is the "Navigation Step" button that can be enabled in a gallery control to move the gallery to the next set of items in the gallery.

The relevant settings are currelly set as such:

Items: Filter( 'Datasource', Condition - Dropdown1.Selected.Value)
Navigation Step: 1
Wrapcount: 1
ShowNavigation: true

The gallery in question is currently sized so it only shows one item at a time and the user is suppossed to use the button to navigate forward or back through the gallery items. However whenever the gallery is first loaded on the web player the "Navigation Step"  button does not move the gallery to the next record.

The only workaround I have found is to set;

Showscrollbar: True

And have the users browse the gallery with the scrollbar, but it is not very intuitive since it is a horizontal gallery where the template is 80% the size of the screen. 

Interestingly enough when the user has scrolled at least once the button starts working and remains working for the remainder of the session.

Community Support
Community Support

Re: Gallery Navigation button not working.

Hi @HISD_JSO ,

I'm sorry that I mistook your issue.

I've made a test and met the same problem like your description.

Here's  another advice:

Turn this setting off

File->App settings->Advanced settings8154.PNG

This setting sometimes effects the app's performance.

 

 

Best regards,

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
HISD_JSO
Frequent Visitor

Re: Gallery Navigation button not working.

Sadly switching that setting has no effect on it. I moved away from using the gallery for that app and used dynamically updated labels instead. Hopefully that particular bug gets worked out in the future.


CurtisJohnson81 Advocate I
Advocate I

Re: Gallery Navigation button not working.

Hey @v-yutliu-msft 

 

This is definitely a bug, is this in the line up to be resolved? I can see that improved app rendering is becoming mandatory imminently, so that won't help either. 

 

Thanks 

 

Curt 

mdatrainer
Regular Visitor

Re: Gallery Navigation button not working.

Are there any updates or workarounds for this issue? 

SkiDK Continued Contributor
Continued Contributor

Re: Gallery Navigation button not working.

Bump, I've got the same problem. Cannot get it to work after trying all solutions offered.

Highlighted
Kevinp
Regular Visitor

Re: Gallery Navigation button not working.

Hi,

 

I also have this issue - the fix for me seems to be increase the Navigation step >1 on the gallery. 

 

Kev

evanderbilt
Regular Visitor

Re: Gallery Navigation button not working.

Same problem here. Using a scrollbar is not ideal

Helpful resources

Announcements
MBAS Gallery 2020

MBAS Gallery 2020

Watch Microsoft Business Applications Summit sessions on-demand.

firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Apps Community!

Top Solution Authors
Top Kudoed Authors
Users online (7,949)