cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
RN2022
New Member

Gallery Tabs fill not updating when selecting different items in Sharepoint List

Dear all,

 

I've created a app linked to a sharepoint list. I've used a gallery to act as my tabs. I've put:

 

If(
ThisItem.IsSelected,
RGBA( 0, 120, 212, 1),

LightGray)

 

in the TemplateFill section of the Gallery. This works fine for when I open the app for the first time and go to different tabs. However, when I close the selected sharepoint item and go to another item the background color of the app doesn't reset to the first tab. Even though the tab does change back to the first tab as I put:  

 

Set(varTabSelected,1)

 

in the on view property of the sharepoint integration section. I don't think it depends on where I put the above mentioned set function as I've even tested it with a separate button but although the tab changes, the color of the tab does not. I would really like the color to also be reset when people switch between items in sharepoint.

1 ACCEPTED SOLUTION

Accepted Solutions
RN2022
New Member

Thank you for your quick response! It did not work sadly but it did send me looking in the right direction. In the end I just needed to add a Reset of my gallery to the onview section of the SharePoint integration part and that did the trick. I found this solution here.

View solution in original post

2 REPLIES 2
iAm_ManCat
Super User
Super User

Maybe have a second variable?

 

During OnVisible of the screen:

Set(gblNoTabsChosen, true)

Then have your fill statement be something like:

If(
   gblNoTabsChosen && ThisItem.TabIDValueThing = varTabSelected,
   RGBA( 0, 120, 212, 1),
   ThisItem.IsSelected,
   RGBA( 0, 120, 212, 1),
   LightGray

)

 

Then your OnSelect that currently sets the varTabSelected value also needs to do:

Set(gblNoTabsChosen, false)

 

 

Cheers,

@iAm_ManCat


Please 'Mark as Solution' if someone's post answered your question and always 'Thumbs Up' the posts you like or that helped you!


Thanks!
You and everyone else in the community make it the awesome and welcoming place it is, keep your questions coming and make sure to 'like' anything that makes you 'Appy
Sancho Harker, MVP


RN2022
New Member

Thank you for your quick response! It did not work sadly but it did send me looking in the right direction. In the end I just needed to add a Reset of my gallery to the onview section of the SharePoint integration part and that did the trick. I found this solution here.

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Difinity Conference 2022

Difinity Conference 2022

Register today for two amazing days of learning, featuring intensive learning sessions across multiple tracks, led by engaging and dynamic experts.

European SharePoint Conference

European SharePoint Conference

The European SharePoint Conference returns live and in-person November 28-December 1 with 4 Microsoft Keynotes, 9 Tutorials, and 120 Sessions.

Power Apps Ideas

Changes to Ideas Coming

We are excited to announce a new way to share your ideas for Power Apps!

Top Solution Authors
Top Kudoed Authors
Users online (5,612)