cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Gallery card height screwed up?

I am having real issues with being able to adjust a gallery card height today.... have tried every type of gallery, have exited powerapps, closed and reopened powerapps in browser, used different browsers (chrome and edge), rebooted system, disabled/enabled autoheight etc etc... all with the same result; no way to adjust the gallery card height. (maxes out at about 50 no matter what)  You can't drag the card or type in values for height.  The type in will accept a number but does not actually change it.  Is there currently an issue with the galleries?  What gives??

1 ACCEPTED SOLUTION

Accepted Solutions
Anonymous
Not applicable

I figured it out!!  Somehow the value of the screen's height got changed to 55 instead of its default value of "Max(App.Height, App.DesignHeight)".  Weird but it seems to be working now that I changed that back.

View solution in original post

9 REPLIES 9
Anonymous
Not applicable

Hi @Anonymous 

 

Is it Gallery or Edit Form.  Can you share screen shot of the same.

 

 

 

 

Thanks.

Anonymous
Not applicable

Problem App.jpgWhat It Should Look Like.jpg

Anonymous
Not applicable

Hi Shailendra- I've attached a few images below.  This seems to be a problem related to this particular app.  I created a new app to test, and the gallery works fine.  It's just being a problem in my actual app.  It will not let me change the height no matter what screen I place the gallery on.

Anonymous
Not applicable

Hi @Anonymous 

 

Got you.  You need to "Edit Gallery" to change the height of your controls.

 

editgallery.PNG

 

 

Also to increase the height, you need to update the "Template Size". This would set the first row and the same would be repeated in subsequent rows of the gallery.

 

Thanks.

Anonymous
Not applicable

Yep, I've done that.  I've got a good amount of experience working with galleries.  This is something definitely odd... feels like a bug.  I manually increased the template size by 1 point and then 1 point more and so on.  I can adjust the template size from between 1 and 55.  At 56 and above, it stops increasing.  I can put in 500 and it looks the same as it does in that previous screenshot.

Hi @Anonymous ,

Actually, the Height property of Gallery card is based on the Template Size property of the Gallery.

 

Please consider modify the Template Size property of the Gallery, then adjust your Gallery card height, check if the issue is solved.

 

Also please consider turn off the "Improved app rendering (final validation)" option within Advanced settings of App settings of your app, re-load your app, check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Hi V-xida.  I've tried changing the template size property.  It simply will not allow a change over 55 pts.  I also changed to classic rendering, restarted.  No difference.  It is only a problem in the app I am working on.  I have started a new app to test and the gallery function works as it is supposed to.  It all started when I renamed a gallery.  I can no longer insert any gallery that now behaves as it should.  Any thoughts as how to remedy this would be greatly appreciated.  Image attached shows 2 galleries on a page in the affected app... that is the max template height that can be acheived.No Improvement.jpg

Hi @Anonymous ,

Currently, I could not reproduce your issue on my side. I think this issue may be related to PowerApps version updates.

 

Please consider submit an assisted support ticket for further help through the following link:

https://powerapps.microsoft.com/en-us/support/pro

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

I figured it out!!  Somehow the value of the screen's height got changed to 55 instead of its default value of "Max(App.Height, App.DesignHeight)".  Weird but it seems to be working now that I changed that back.

View solution in original post

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (2,219)