cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ahhollan
Helper V
Helper V

Gallery is blank

I have tried to create an app from a datasource (SP list). However, app doesn't show any records in the gallery.  The formula in the gallery items property is SortByColumns(Filter([@'Project Initiation'], StartsWith(Title, TextSearchBox1.Text)), "Title", If(SortDescending1, Descending, Ascending)) .  However, when the search field is blank, the gallery doesn't return any items. Thoughts?

8 REPLIES 8
mdevaney
Super User
Super User

@ahhollan 

When the text input ISBLANK a condition of True will show all records.  Make this small change to your code.  

 

 

 

SortByColumns(
    Filter(
        [@'Project Initiation'],
        If(IsBlank(TextSearchBox1.Text),True,StartsWith(Title, TextSearchBox1.Text))
    ),
    "Title",
    If(SortDescending1, Descending, Ascending)
)

 

 

 

---
Please click "Accept as Solution" if my post answered your question so that others may find it more quickly. If you found this post helpful consider giving it a "Thumbs Up."

DisappointmentB
Advocate III
Advocate III

Hello,

 

The formula is expecting a result to be in the search box. You can check to see if the search text is blank. If it is then simply return all the results and if not use the formula you have.

 

Regards

 

Ben

I made the change and still get errors.

 

11-14-2019 10-09-18 AM.png

 

 

 

Hi,

 

I would separate the formula out so that it is easier to read and see the errors. So:

 

If(IsBlank(TextInput1.Text),

SortByColumns([@'Project Initiation'],"Title", If(SortDescending1, Descending, Ascending)) ,

SortByColumns(Filter([@'Project Initiation'], StartsWith(Title, TextSearchBox1.Text)), "Title", If(SortDescending1, Descending, Ascending)))

 

 

@ahhollan 

It would be helpful to know what error messages you are receiving.

11-14-2019 10-48-45 AM.png

 

That helped, but now I get...

 

 
 

Hello,

 

Someone with the same problem of the Lookups asked here and a solution has been given. Would be worth checking if you have the same situation.

 

https://powerusers.microsoft.com/t5/Building-Power-Apps-Formerly/Error-The-query-cannot-be-completed...

@DisappointmentB 

Agreed this is a SharePoint issue.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (2,034)