cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Gallery items reset issue/bug

I have created a simple app that has one Gallery with label,Radio and button control.

The button control is supposed to reset radio control to default.

For each item in the gallery, button resets the radio control but the first item of the gallery.

Is this a bug or desired behaviour (being template item can not be reset)?

Reset Radio.OnSelect-> Reset(Radio1)

Radio1.Reset->true

Radio1.Default-> "  "

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @Anonymous,

 

If you experience difficulties with the new canvas, we’ve provided a toggle ("Render in classic mode" option) under the advanced settings so that you can revert back to the previous experience. This option will disable the new canvas so that you can go back to the classic experience.

 

If you have solved your problem, please go ahead and click “Accept as Solution” so that this thread will be marked for other users to easily identify.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

6 REPLIES 6
PeteMc
Resolver I
Resolver I

Try putting the radio button on a form and then reset the form instead.
v-xida-msft
Community Support
Community Support

Hi @Anonymous,

 

Could you please share a bit more about your scenario?

Do you mean that the Radio control within the first item of the Gallery control could not be reset when you click the Reset button?

 

Based on the formula that you provided, I have made a test (On Chrome Browser within Windows10) and the issue is confirmed on my side.

 

But when I have made a test on the Chrome Browser within Mac OS, this issue doesn't occur. You could also consider take a try to run your app on PowerApps Mobile App within Android Device or iOS device, then check if the issue is still existed.

 

In addition, you could also take a try to enable/turn on the "Render in classic mode" option within the Advanced settings of App Settings (App settings-> Advanced Settings->"Render in classic mode" option), then check if the issue is solved on your side.

 

I would also post this issue to my product team, if this issue is solved, I would reply here.

 

 

Best regards,

Kris

 

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable


@v-xida-msft wrote:


Do you mean that the Radio control within the first item of the Gallery control could not be reset when you click the Reset button?

Yes. Only the first item could not be reset. 

 

Based on the formula that you provided, I have made a test (On Chrome Browser within Windows10) and the issue is confirmed on my side.

 

But when I have made a test on the Chrome Browser within Mac OS, this issue doesn't occur. You could also consider take a try to run your app on PowerApps Mobile App within Android Device or iOS device, then check if the issue is still existed.

I tried with Microsoft Edge, Goole Chrome and Internet Explorer. Result is same. I also tried on my Android cell phone but no go.

 

In addition, you could also take a try to enable/turn on the "Render in classic mode" option within the Advanced settings of App Settings (App settings-> Advanced Settings->"Render in classic mode" option), then check if the issue is solved on your side.

That did the trick. I changed the app setting to "Render in classic mode" as you suggested and NOW I can reset even the first item. I have to use the Gallery control insted of the form control for my application.

 

I would also post this issue to my product team, if this issue is solved, I would reply here.

 

 

Best regards,

Kris

 


What is so different about "Render in classic mode"? Just curious.

Last but not least, thank for help. 🙂 

Hi @Anonymous,

 

If you experience difficulties with the new canvas, we’ve provided a toggle ("Render in classic mode" option) under the advanced settings so that you can revert back to the previous experience. This option will disable the new canvas so that you can go back to the classic experience.

 

If you have solved your problem, please go ahead and click “Accept as Solution” so that this thread will be marked for other users to easily identify.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Anonymous
Not applicable

Render in Classic mode solved the problem. I will mark your answer as an acceptable solution but for the other developers who are not aware of this fix, is PowerApps team going to recognize this as bug and fix in the next release?

I have tried both now and noting resets a checkbox in a gallery.  I have an old app with a textbox in a gallery and this reset every time.  Is it just checkboxes with the problem?

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (1,626)