cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
JosL
Regular Visitor

Gallery selected property being cleared when the next screen has loaded

I have a gallery (A), in which I select a row, which brings me to a new screen where I show the selected ID of A, and another gallery (B) for a different azure paas sql table. When I select a row on B, I go to another screen that shows me the selected ID of A and the selected ID of B, this is where funny stuff happens:

 

1. first time I click in B, the new screen shows the ID of A and B for a second or two, then the ID of B dissappears (becomes null?)

2. if I click back, and click the same row again, both ID's are shown properly.

3. if I then edit one of the rows (B), the same happens, first it doesn't load properly, then the second time it does.

 

I haven't configured anything on these three screens that I think could overwrite the gallery selection (don't even know how to, yet). And even if that was the case, why would it only work once?

 

Any clues? 🙂

7 REPLIES 7
RandyHayes
Super User III
Super User III

@JosL 

What are you doing in your OnSelect action in the Gallery/ies?

Do you have any OnVisible actions going on?

What is your formula on the other screen that shows the ID's of A and B?

 

Hopefully you can check those and see an issue, but if not, post back and we'll explore more.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

@RandyHayes 

I've tried two approaches, one selecting the parent when a row is clicked, the parent has a navigate() in its OnSelect, and doing the navigate() in the row itself. Both methods (not at the same time) cause the same issue.

No OnVisible actions going on.

 

Formula to show the values is just a Concatenate, example:

Concatenate("ID of A: ",Text(A.Selected.id), " & B: ",Text(B.Selected.id))

@JosL 

That seems pretty much good.

A bit of a mystery!  The only suggestion I might make at this point (since it's pretty simple of an App) is to create a new app and do only those same items - 2 galleries.  Navigate (OnSelect of Parent or on the Row is fine).  A label with the ID's.

See if you have the exact same issue in a fresh App.  If not, then there has got to be something else in your first one that is at fault.  If so...then the mystery continues.  Let's see what's next.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

@RandyHayes New apps don't have this issue....one thing I forgot to mention, if I run the app in the editor, the issue doesn't occur, it only occurs when directly starting/using the app, mobile or browser.

So yeah...mysterious 🙂

@JosL  

Oh sure...throw a little more mystery in the machine 😉

 

Ok - to be clear.  You are saying that if you create a new app that has this exact functionality - it works fine in the Player.  Only this current app has issues in the Player only.

If that statement is correct, then again, we're looking at something in the App that is causing it.  If it is not some formula that is mixed in someplace that perhaps you "misplaced", then I would review the App Settings of the working vs the non-working app to see if perhaps there is a setting that is causing the difference.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

@RandyHayes Doesn't the fact that it doesn't work in the player, but works in the editor show that there is a bug of some kind causing this?

 

It's a big app, and the screens that have this issue don't have functions/formula's that I think could cause this, but in either case, shouldn't the issue then be present in the editor as well?

@JosL 

Potentially a discrepency between the editor and player.  They are certainly two different applications.

I do find that sometimes you "work around" issues to make it look right or work right in the editor, only to find that the "solution" fails in the player because it seems the player is less forgiving of sins.  

The only thing I can say in this case, is that I've been there...seen situations where something strange is going on.  My first inclination is that there is some type of bug, but almost every time I find that there was some wacky thing that I was doing some place else in the App that was causing the issue.

This is where, usually, my last troubleshooting step is a fresh app designed with *only* the problem I am experiencing in it.  I usually find then that the problem is gone...so, it's back to the original to hunt down the culprit.  And yes, it is more challenging when it is a player vs editor issue that I'm after.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Don't miss the call this month on June 16th - 8a PDT

Top Solution Authors
Top Kudoed Authors
Users online (50,668)