cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Ardions
Helper I
Helper I

Gallery showing wrong data for users

Hi experts,

I have a gallery with SPList as database. Unfortunately for some reason the gallery is not showing all items properly. When I as an owner open the app, I see all 291 items as shown in my SPList, but my users only see 87. They have the same access rights in the List as I do.  Do you know what the problem could be??

1 ACCEPTED SOLUTION

Accepted Solutions
rsaikrishna
Super User
Super User

@Ardions 

 

You may need to check the following:

1. Are you using Filter function on the datasource for the gallery? If so, you may need to check if the filter function on the metadata is causing the issue?

2. Do you have item level permisions in the SP list?

 

Please post your observations here.

 

Regards

Krishna Rachakonda

If this reply helped you to solve the issue, please mark the post as Accepted SolutionMarking this post as Accepted Solution, will help many other users to use this post to solve same or similar issue without re-posting the issue in the group. Saves a lot of time for everyone.

View solution in original post

3 REPLIES 3
rsaikrishna
Super User
Super User

@Ardions 

 

You may need to check the following:

1. Are you using Filter function on the datasource for the gallery? If so, you may need to check if the filter function on the metadata is causing the issue?

2. Do you have item level permisions in the SP list?

 

Please post your observations here.

 

Regards

Krishna Rachakonda

If this reply helped you to solve the issue, please mark the post as Accepted SolutionMarking this post as Accepted Solution, will help many other users to use this post to solve same or similar issue without re-posting the issue in the group. Saves a lot of time for everyone.

@rsaikrishna 
hi, this is how I'm filtering the gallery:
Sort(
If(
IsBlank('filter-dpt'.Selected.Name),
Filter(
'Quality evaluator',
IsBlank('First evaluator')
),
Filter(
'Quality evaluator',
'filter-dpt'.Selected.Name in Department.Value,
IsBlank('First evaluator')
)
),
Created,
Descending
)


And the permission level is the same for me and users.

@rsaikrishna hey, after changing the flow and adjusting the items permissions, I'm still getting the errors. Any idea of what else could be causing the problem?

Helpful resources

Announcements
PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Top Solution Authors
Top Kudoed Authors
Users online (2,333)