cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Gallery showing wrong data for users

Hi experts,

I have a gallery with SPList as database. Unfortunately for some reason the gallery is not showing all items properly. When I as an owner open the app, I see all 291 items as shown in my SPList, but my users only see 87. They have the same access rights in the List as I do.  Do you know what the problem could be??

1 ACCEPTED SOLUTION

Accepted Solutions
rsaikrishna
Community Champion
Community Champion

@Anonymous 

 

You may need to check the following:

1. Are you using Filter function on the datasource for the gallery? If so, you may need to check if the filter function on the metadata is causing the issue?

2. Do you have item level permisions in the SP list?

 

Please post your observations here.

 

Regards

Krishna Rachakonda

If this reply helped you to solve the issue, please mark the post as Accepted SolutionMarking this post as Accepted Solution, will help many other users to use this post to solve same or similar issue without re-posting the issue in the group. Saves a lot of time for everyone.

View solution in original post

3 REPLIES 3
rsaikrishna
Community Champion
Community Champion

@Anonymous 

 

You may need to check the following:

1. Are you using Filter function on the datasource for the gallery? If so, you may need to check if the filter function on the metadata is causing the issue?

2. Do you have item level permisions in the SP list?

 

Please post your observations here.

 

Regards

Krishna Rachakonda

If this reply helped you to solve the issue, please mark the post as Accepted SolutionMarking this post as Accepted Solution, will help many other users to use this post to solve same or similar issue without re-posting the issue in the group. Saves a lot of time for everyone.
Anonymous
Not applicable

@rsaikrishna 
hi, this is how I'm filtering the gallery:
Sort(
If(
IsBlank('filter-dpt'.Selected.Name),
Filter(
'Quality evaluator',
IsBlank('First evaluator')
),
Filter(
'Quality evaluator',
'filter-dpt'.Selected.Name in Department.Value,
IsBlank('First evaluator')
)
),
Created,
Descending
)


And the permission level is the same for me and users.

Anonymous
Not applicable

@rsaikrishna hey, after changing the flow and adjusting the items permissions, I'm still getting the errors. Any idea of what else could be causing the problem?

Helpful resources

Announcements
Power Platform Call June 2022 768x460.png

Power Platform Community Call

Join us for the next call on August 17, 2022 at 8am PDT.

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Users online (1,865)