cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Resolver I
Resolver I

Gallery with on prem sql data source issue

Hi All,

 

Running into an issue when I have a gallery with source 

 

Filter('[dbo].[clientdata]', ClientIDInputbox.Text in ClientID)

That part works fine, I enter the client ID in the ClientIDInputbox and the gallery is filtered based on that clientID.

 

The issue I'm having is I have a flow that retrieves some info from this gallery such as client responsible, client name and client office which are text labels, but the flow fails with the error invalid value for parameter.

 

The issue is it thinks the fields are blank because if I use a text label to display data from that gallery such as 

Text = ClientName 

or

Text = ClientName.text

 

The text label is just blank, thus I cannot pull the data from the gallery into my flow. This worked flawlessly last month and I have not changed anything in the app or my data sources/connections. 

 

Any suggestions?

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Hi @v-micsh-msft ,

 

I had a call with Microsoft Tech Support on this issue and they confirmed it's a known bug and there is no ETA on the fix.

 

They suggested to use a list or a collection as a workaround in the meantime instead of a gallery.

 

 

View solution in original post

2 REPLIES 2
Highlighted
Community Support
Community Support

What is your ccurrent situation?

 

Would you please let me know your Flow configuration, and the value you are trying to put within it?

 

Besides, could you please share more details about your data source, s[pecially for the field type?

Within the DataCard control of the galley, please consider switch the Text property of Label control to:

ThisItem.Columname

For the Flow.run(), make sure you use the Gallery.Selected.ClientName as the Value input, after that, check to see if it would work.

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted

Hi @v-micsh-msft ,

 

I had a call with Microsoft Tech Support on this issue and they confirmed it's a known bug and there is no ETA on the fix.

 

They suggested to use a list or a collection as a workaround in the meantime instead of a gallery.

 

 

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (8,865)