cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DaniOrt
New Member

Gateway not found

Hi, i´m trying to connect to an on premise database. When creating de conection i´m not able to select my gateway. In "Gateways" option there is no gateways. I´ve installed one and singed in. I had a Power BI Gateway installed previously and seems to ver recognized by the Power Apps Gateway Installer.

 

In Power Bi everything is working fine but not in Power Apps.

In the log there´s only this entrance "Started the 'On-premises data gateway service'."

 

Thank you

 

PA_gateway.png

1 ACCEPTED SOLUTION

Accepted Solutions

Uninstalling the PowerBI Gateway (old version) and installing the On-premise data gateway version seems to fix the problem.

View solution in original post

21 REPLIES 21
archanan
Power Apps
Power Apps

Gateways are only supported in the default environment.

 

https://powerapps.microsoft.com/en-us/tutorials/gateway-management/

 

Could you double check to confirm you are in the right environment in PowerApps?

 

https://powerapps.microsoft.com/en-us/tutorials/working-with-environments/

Thanks @archanan.

Yes, i´m in the default environment and still not working.

 

Can you please share your session ID so we can look into this further?

 

Account -> Session details and copy paste the Session ID. Thanks!

We are investigating this issue. I sent you a message as well. If you can email me your logs, it will help us investigate further.

The same issue is also happening with our on-premises gateway, "no gateays installed" message appears in the "Gateways" even though the PowerBI gateway is up and running. Also, in the event viewer there is an error starting from the moment the data gateway was installed, with the following message:

 

Log Name: System
Source: Schannel
Date: 8/11/2016 5:23:56 μμ
Event ID: 36882
Task Category: None
Level: Error
Keywords:
User: NT SERVICE\PBIEgwService
Computer: ------
Description:
The certificate received from the remote server was issued by an untrusted certificate authority. Because of this, none of the data contained in the certificate can be validated. The SSL connection request has failed. The attached data contains the server certificate.

We have seen some issues with PowerBI Gateways that were installed prior to our release of the PowerApps support. Could you please try these steps to see if that resolves the issue?

 

  1. Uninstall the gateway
  2. Download the updated/latest version
  3. Restore the Gateway using the recovery key

With your recovery key, you will be able to restore all your datsources and settings.

I'm having the same problem.

@DaniOrt@ssugar@tsapat, Do you still have the same issue that not found the gateway even if tried @archanan's steps? 

Uninstalling the PowerBI Gateway (old version) and installing the On-premise data gateway version seems to fix the problem.

Helpful resources

Announcements
Power Apps Africa Challenge 2022

Power Apps Africa Challenge

Your chance to join an engaging competition of Power Platform enthusiasts.

Super User 2 - 2022 Congratulations

Welcome Super Users

The Super User program for 2022 - Season 2 has kicked off!

September Events 2022

Check out all of these events

Attend in person or online, there are incredible conferences and events happening all throughout the month of September.

Government Carousel

New forum: GCC, GCCH, DoD - Federal App Makers (FAM)

In response to the unique and evolving requirements of the United States public sector, Microsoft has created Power Apps US Government.

Users online (2,343)