cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Delid4ve
Impactful Individual
Impactful Individual

Gateways not showing

My Gateway is working however under data - Gateways it is showing no gateways installed.

Can somebody else please confirm as i cant add any connections to my on prem data as no gateways are listed.

45 REPLIES 45

We had the same issue with our PowerApps/Flow. Within PowerApps we could no longer see our Gateway. This Gateway still worked with PowerBI. The problem was the Gateway default region/data centre (https://azure.microsoft.com/en-us/global-infrastructure/locations/).

We discovered our PowerApps Environment had changed the region/data centre it looked at. (Don't know why it changed). Originally our PowerApps looked at the UK South Region, now it looks at the North Europe region. Therefore when our original Gateway was installed it automatically defaulted to look at the UK South region (data centre).

Because our PowerApps Envirnoment was changed to look at the North Europe region, PowerApps couldn't see any Gateway, because it didn't exist in that region/data centre.

The default region can be changed when setting up the Gateway, see attached image.

To fix this problem we created 2 separate Gateways on 2 separate servers. One Gateway set to the UK South region for PowerBI and the other Gateway set to North Europe region for PowerApps.

Thank you @Vinnie I have checked the environment on the Gateway, it says UK South.

I finally found thanks to this link how to check the Power Apps region.

It shows as Europe.

No wonder it can't find a gateway! Thank you for pushing me to look closer at Regions.

 

I found the Change Region bit you highlighted for me (THANK YOU!), but the options include North Europe and South Europe - but Power Apps looks to Europe... 😕 Thanks Microsoft...

 

Luckily I took your advice and chose North Europe - IT WORKS!! 😄 THANK YOU!

You're welcome @james_goodhew  delighted it worked.

I tested a Gateway set to the West Europe region data centre and it also works with my PowerApps Environment.

Still not sure why our PowerApps and PowerBI environments are pointing to different regions. 

Goodo, yes very strange.

Just as a gift for a Friday afternoon, I then got it to recognise the gateway, it showed up in my Flow, and... said "your license does not allow you to use gateways". >_< After all that effort!!

 

[rage]

Why allow us to see the File System Connector as NOT "Premium" yet the single most important prerequisite is a PAID FOR component? 

[/rage]

Inrade
Frequent Visitor

Does anybody have a solution for this? I have several gateways in Power BI for which I am a User and several for which I am an admin. When I look under Gateways in Power Automate or Power Apps I only see the ones for which I am an admin. How can this be solved? I've asked IT to update/reinstall the gateways but to no avail.

Have you checked the regions? That’s most likely the issue. 

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Top Kudoed Authors
Users online (4,037)