cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Get response content from Custom Connector

Hi everyone,

 

I have created a custom connector for a local REST service. While testing within the editor I don't get any errors and the response of the service is displayed correctly.
But when I use the function in Power Apps the collection stores an entry but it is empty.

I attached screenshots for the function and the collection in power apps and the test in the editor.

 

Thanks

Julian

12 REPLIES 12
Highlighted
Super User III
Super User III

Re: Get response content from Custom Connector

Hi Julian,

To diagnose this, I'd replace the control references with hard coded values to check whether it could be incorrect or blank values that causes your connector to not return data.

 

timl_0-1598521049293.png

 

Also, how did you define bb_zeitstempel in your Swagger/OpenAPI? Is it a string or a date parameter? If you defined it as string, you might need to call Text(Now()) to convert it to a string.

Highlighted
Frequent Visitor

Re: Get response content from Custom Connector

@timl Hey, 

 

replacing the references with hard coded values didn't work.

The "bb_zeitstempel" is defined as a string. However, changing this didn't help either.

Highlighted
Super User III
Super User III

Re: Get response content from Custom Connector

Hi @Julian_Postertz 

I'm not sure what to suggest unfortunately. Are you able to trace your REST service to see if it's receiving the HTTP request correctly, and that it's sending the output that you expect?

Highlighted
Frequent Visitor

Re: Get response content from Custom Connector

@timlNo i can't, the REST service is provided by another company.

Highlighted
Super User III
Super User III

Re: Get response content from Custom Connector

Hi @Julian_Postertz 

Although this might sound obvious, are you sure that you're not receiving any data at all?

If you drill into the besuchbericht field by clicking the empty cell, do you see column headers for your bb_number and bb_status fields?

 

timl_0-1598609956214.png

 

Highlighted
Frequent Visitor

Re: Get response content from Custom Connector

@timl 

I can't click into the field, nothing happens.
Guess it is because there is no object?

Highlighted
Super User III
Super User III

Re: Get response content from Custom Connector

Yes, I guess it might be because there's no object. Just to confirm, if you add a label and set the text property to the following, does it return any data?

First(PostAtwortAD).besuchbericht.bb_number

Highlighted
Frequent Visitor

Re: Get response content from Custom Connector

The label shows no text.

But there is also no error.

Highlighted
Super User III
Super User III

Re: Get response content from Custom Connector

Hi @Julian_Postertz 

The diagnose this further, the next thing I would suggest would be to create a PowerAutomate Flow and to call your custom connector from a Flow.

When you run the Flow, you can examine the Flow history and see the exact response that the server sends. This can help you identify whether or not the REST service returns no data, and I think that's the best way to move forwards given that you have no access to the server.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Tech Marathon

Maratón de Soluciones de Negocio Microsoft

Una semana de contenido con +100 sesiones educativas, consultorios, +10 workshops Premium, Hackaton, EXPO, Networking Hall y mucho más!

Top Solution Authors
Top Kudoed Authors
Users online (7,029)