cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
daroot
Resolver I
Resolver I

GetMap error

Hi All,

Anyone faced the issue BingMap error? I am used UserLat as Latitude and UserLon as Longitude
6 REPLIES 6
timl
Super User
Super User

Hi @daroot

It sounds like the Latitude value that you're passing to GetMap is incorrect. Can you confirm what UserLat and UserLon are? Where are you setting these in your app?

Hi @timl,

I am used this on the view record page within gallery. I put this on the Image control:

BingMaps.GetMap(
"Road",
10,
UserLat, UserLon,
{pushpin:UserLat & "," & UserLon})

The UserLat field is a Lotitude value, and UserLon is a Longitude value. On the PowerApps studio didn't show any errors. Should I changed the UserLat field name to Latitude in SPList?

Thanks for any advice

Hi @daroot

I would suggest that you add a label to your screen and set Text property to your formula.

When you run your app, the label should show the actual arguments that you're passing to the GetMap function. This should help you diagnose the problem, or you could post the result here if you're still stuck.

Hi @timl,

 

Tried your suggestion, but the error still exist. Anyway is there any better way to embed imagemap in the app instead used my previous code?

 

Thanks,

Hi @daroot

When you added the label, what did the label say when you ran the app?

Hi @timl,

It display the same error, latitude not found 😞

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (3,534)