cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
daroot
Resolver I
Resolver I

GetMap error

Hi All,

Anyone faced the issue BingMap error? I am used UserLat as Latitude and UserLon as Longitude
6 REPLIES 6
timl
Super User
Super User

Hi @daroot

It sounds like the Latitude value that you're passing to GetMap is incorrect. Can you confirm what UserLat and UserLon are? Where are you setting these in your app?

Hi @timl,

I am used this on the view record page within gallery. I put this on the Image control:

BingMaps.GetMap(
"Road",
10,
UserLat, UserLon,
{pushpin:UserLat & "," & UserLon})

The UserLat field is a Lotitude value, and UserLon is a Longitude value. On the PowerApps studio didn't show any errors. Should I changed the UserLat field name to Latitude in SPList?

Thanks for any advice

Hi @daroot

I would suggest that you add a label to your screen and set Text property to your formula.

When you run your app, the label should show the actual arguments that you're passing to the GetMap function. This should help you diagnose the problem, or you could post the result here if you're still stuck.

Hi @timl,

 

Tried your suggestion, but the error still exist. Anyway is there any better way to embed imagemap in the app instead used my previous code?

 

Thanks,

Hi @daroot

When you added the label, what did the label say when you ran the app?

Hi @timl,

It display the same error, latitude not found 😞

Helpful resources

Announcements
User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Power Apps Community Call Jan. 2022 768x460.png

Power Apps Community Call

Please join us on Wednesday, January 19th, at 8a PDT. Come and learn from our amazing speakers!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Solution Authors
Top Kudoed Authors
Users online (2,646)