cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MBilal-079
Frequent Visitor

Getting an Error on Post Action in Custom Connector Power Apps (Xero Connector)

Hi, 

 

I'm trying to connect with Xero using a custom connector in Power Apps, I got the invoices in power apps but couldn't run the Post request operation to delete the invoice, API and connection are running perfectly because I tested the Post request Action in Custom Connector, there it is running fine, but in the App it is creating an error. 
The error is AuthenticationUnsuccessfull, but this error is not appearing in the Test of the custom connector. why in the App?

 

Xero-Connector.png

-----

Xero-Connector2.png

 

Thanks 

 

Muhammad Bilal

1 ACCEPTED SOLUTION

Accepted Solutions
MBilal-079
Frequent Visitor

I fixed it, in my case the tenant-id was null when I call it from the App, that's why the error is "AuthenticationUnsuccessful". 

 

after giving the tenant-id it is running fine. 

View solution in original post

1 REPLY 1
MBilal-079
Frequent Visitor

I fixed it, in my case the tenant-id was null when I call it from the App, that's why the error is "AuthenticationUnsuccessful". 

 

after giving the tenant-id it is running fine. 

Helpful resources

Announcements
PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Top Solution Authors
Top Kudoed Authors
Users online (3,258)