cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate I
Advocate I

Getting your data...

Hi All,

 

Do somebody know how can I change/remove the "Getting your data ..." text from the form when the filter didnt find a match? Sometimes it shouldnt find anything, but the "Getting your data ..." text is missleading, users are thinking that the system is still loading when actually it didnt find anything.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Helper I
Helper I

Re: Getting your data...

Seems this isn't really a built in option looking at the previous reply, but you can certainly devise a workaround!

 

Create a label with a Fill matching that of your form, then set the text to whatever message you may like to appear when the form finds no data. You can set this label's X/Y properties to a percentage of the form's total height/width so that it is placed over the "Getting your data" message, "replacing" it, regardless of any resizing that may occur to the form when displayed on different devices. May take some tooling to get it just right. Make sure that this is at the lowest layer of the controls present on this form so it doesn't impede interaction with any other controls.

 

Once you've got it all positioned correctly, set its OnVisible property as such:

If(
    IsEmpty(Filter(yourdatasource, your filter), True, False)
)

Which will cause the label to appear only when the filter turns up with nothing,  covering the default message.

 

Let me know if this works out for you!

 

 

View solution in original post

6 REPLIES 6
Highlighted
Community Support
Community Support

Re: Getting your data...

Hi @Papancsev ,

 

I think this message cannot be hidden so far, if you need this feature, consider to add an idea in below forum here:

https://powerusers.microsoft.com/t5/PowerApps-Ideas/idb-p/PowerAppsIdeas

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Advocate I
Advocate I

Re: Getting your data...

Hi Mona,

 

I think its more like a bug than an improvement idea. 

When nothing is found it should say that and not "Getting your data..." as its not true.

Highlighted
Community Support
Community Support

Re: Getting your data...

Hi @Papancsev ,

 

Did you mean that when your users do not have the access to the data, then still get the same message when opening the app?

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Helper I
Helper I

Re: Getting your data...

Seems this isn't really a built in option looking at the previous reply, but you can certainly devise a workaround!

 

Create a label with a Fill matching that of your form, then set the text to whatever message you may like to appear when the form finds no data. You can set this label's X/Y properties to a percentage of the form's total height/width so that it is placed over the "Getting your data" message, "replacing" it, regardless of any resizing that may occur to the form when displayed on different devices. May take some tooling to get it just right. Make sure that this is at the lowest layer of the controls present on this form so it doesn't impede interaction with any other controls.

 

Once you've got it all positioned correctly, set its OnVisible property as such:

If(
    IsEmpty(Filter(yourdatasource, your filter), True, False)
)

Which will cause the label to appear only when the filter turns up with nothing,  covering the default message.

 

Let me know if this works out for you!

 

 

View solution in original post

Highlighted
Advocate I
Advocate I

Re: Getting your data...

Thank you Hooze! I was thinking on this solution, if there is no "official" one, I will do the workaround as you suggested.

Highlighted
Helper III
Helper III

Re: Getting your data...

Agreed.

I got same issue.

in Preview, the form will show "No data to display" if find no match record.

in Play after publish, the form will keep showing "getting your data" even there is no match data.

anyway I can use the workaround, but this need to be fixed. thanks.

Snipaste_2020-05-25_13-02-34.jpg

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Robotic Process Automation

Let's talk about the solution provided by Microsoft for Robotic Process Automation (RPA)

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

Top Solution Authors
Top Kudoed Authors
Users online (6,225)