cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Km00
Helper III
Helper III

Global variables just stopped working

i have a live app thats been working just fine for over a week, now today half of it is broken.

I've narrowed it down to i believe the global variables not pulling the data. the Local variables are pulling correctly without issue.

 

Nothing was touched in this app, nothing changed, it just stopped working correctly.

 

WHY OH WHY !  i see that power apps updated AGAIN and i swear almost every single time they do this something breaks. a newly live app to the company and just stops working.

 

Is anyone else having the issue?  I seem to not be able to find where there are current issues out there.

1 ACCEPTED SOLUTION

Accepted Solutions
v-qiaqi-msft
Community Support
Community Support

Hi @Km00,

Do you mean that you global variable doesn't work any more?

Could you please share a bit more about your scenario?

 

If it is related to the Power Apps updates, you should roll back to your older version.

vqiaqimsft_0-1634700425930.png

You must do this every time you want to open.

In a word, open your latest version of the new app and changed version to your older version. 

 

In addition, please check how you trigger the variable. If it is triggered by some action, make sure that you have acted as before.

Best Regards,
Qi

View solution in original post

3 REPLIES 3
BCBuizer
Super User
Super User

Hi KM00,

 

I had a similar experience about a week ago. Global variables just didn't seem to get a value. This seemed especially the case when I was in an MS Teams call whilst presenting my screen. Since I was sharing my screen to give demos, it was highly annoying!



Did you like my post? Please give it a thumbs up! Did I resolve your issue? Please click Accept as Solution to close the topic and so other members of the community can find solutions more easily.
v-qiaqi-msft
Community Support
Community Support

Hi @Km00,

Do you mean that you global variable doesn't work any more?

Could you please share a bit more about your scenario?

 

If it is related to the Power Apps updates, you should roll back to your older version.

vqiaqimsft_0-1634700425930.png

You must do this every time you want to open.

In a word, open your latest version of the new app and changed version to your older version. 

 

In addition, please check how you trigger the variable. If it is triggered by some action, make sure that you have acted as before.

Best Regards,
Qi
skelecopter
Helper II
Helper II

Did you ever resolve this? I am having the same issue and wanting to tear my hair out!

Helpful resources

Announcements
Power Apps News & Annoucements carousel

Power Apps News & Announcements

Keep up to date with current events and community announcements in the Power Apps community.

Community Call Conversations

Introducing the Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Apps Community Blog Carousel

Power Apps Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (3,062)