cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
omaffud
Frequent Visitor

Google Chrome is not opening attachments

I made a PowerApps form based on SharePoint list.
Using IE and Edge, when I open the form in SharePoint and click on the attachment name, download works. But in Chrome nothing happens.

Anyone here faced this problem before?

Thanks,

18 REPLIES 18
richdiMSFT
Power Apps
Power Apps

Hi 

With the update to Chrome 83 there is an issue where Chrome blocks file downloads from within iframes. At this time you will need to use the default SharePoint Form or a different browser. We are working on a fix but it will take awhile to be deployed. 

 

Sorry for the issue!

Rich Dickinson

PM Power Apps

Oh No! This is quite a major problem for me. I hope you can fix it soon. I wonder why Google have done this???

This is a big problem, I hope there is a quick fix or else we will have to find a different platform.

Hi @richdiMSFT - our Business has been scratching their heads for a few days on this one, thank you for the info. The majority of users who've reported this issue are on the mentioned problematic Chrome v83 version, however, at least one of the users is having an issue on v79.0 

 

Do we know if this issue is only known to v83, or is it possible it's affecting this earlier v79 as well? 

 

Thank you,

Morghan Castorena

cchan000
Helper V
Helper V

Microsoft please pay attention to this. This is absolutely an issue. I can verify can't open attachments on chrome.

bhu128
Advocate I
Advocate I

We are experiencing this as well, also happening when we access it through the Teams app. 

Hi all,

 

I wanted to update this thread. The teams are working to have the fix fully deployed by the end of next week baring any issues with deployment. 

 

I will keep the item updated on this document page: https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/common-issues-and-resolutions?branch=ma...

Sorry updated link to published article! 

 

Sorry for the pain,

Rich Dickinson

PM Power Apps

This issue is caused by a specific change in Chrome's handling of sandboxed iframes which was introduced in version 83.

 

So there must be a different issue for the user on version 79. 

 

Rich Dickinson

PM Power Apps

Good morning @richdiMSFT -

 

I am receiving a permissions error when attempting to access the link in your post, but I appreciate the update in this thread! I will check back with my problematic users next week post-deployment.

 

Thank you,
Morghan

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (2,191)