cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Graph Custom Connector - Object not set to an instance of an object

I have got a custom connector setup for Microsoft graph as per https://powerapps.microsoft.com/en-us/blog/implementing-role-based-permission/ and this has been running without an issue for a couple of months.

 

This morning though when we have opened the app, this connector is coming up with an error:

 

<!DOCTYPE html>
<html>
<head>
<title>Object reference not set to an instance of an object.</title>
<meta name="viewport" content="width=device-width" />
<style>
body {font-family:"Verdana";font-weight:normal;font-size: .7em;color:black;}
p {font-family:"Verdana";font-weight:normal;color:black;margin-top: -5px}
b {font-family:"Verdana";font-weight:bold;color:black;margin-top: -5px}
H1 { font-family:"Verdana";font-weight:normal;font-size:18pt;color:red }
H2 { font-family:"Verdana";font-weight:normal;font-size:14pt;color:maroon }
pre {font-family:"Consolas","Lucida Console",Monospace;font-size:11pt;margin:0;padding:0.5em;line-height:14pt}
.marker {font-weight: bold; color: black;text-decoration: none;}
.version {color: gray;}
.error {margin-bottom: 10px;}
.expandable { text-decoration:underline; font-weight:bold; color:navy; cursor:hand; }
@media screen and (max-width: 639px) {
pre { width: 440px; overflow: auto; white-space: pre-wrap; word-wrap: break-word; }
}
@media screen and (max-width: 479px) {
pre { width: 280px; }
}
</style>
</head>

<body bgcolor="white">

<span><H1>Server Error in '/' Application.<hr width=100% size=1 color=silver></H1>

<h2> <i>Object reference not set to an instance of an object.</i> </h2></span>

<font face="Arial, Helvetica, Geneva, SunSans-Regular, sans-serif ">

<b> Description: </b>An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

<br><br>

<b> Exception Details: </b>System.NullReferenceException: Object reference not set to an instance of an object.<br><br>

<b>Source Error:</b> <br><br>

<table width=100% bgcolor="#ffffcc">
<tr>
<td>
<code>

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.</code>

</td>
</tr>
</table>

<br>

<b>Stack Trace:</b> <br><br>

<table width=100% bgcolor="#ffffcc">
<tr>
<td>
<code><pre>

[NullReferenceException: Object reference not set to an instance of an object.]
Microsoft.Online.AggregatorService.Common.Gateway.AgsIndexConfigProvider.GetConfigVersionNumber(String configType, String configId) in d:\bt\932496\repo\src\dev\Common\Gateway\AgsIndexConfigProvider.cs:64
Microsoft.Online.AggregatorService.Common.Gateway.ConfigurationProvider`1.GetConfigurationImp(String identifier, Boolean useCache) in d:\bt\932496\repo\src\dev\Common\Gateway\ConfigurationProvider.cs:389
Microsoft.Online.AggregatorService.Common.Gateway.ConfigurationProvider`1.GetConfiguration(String identifier, Boolean useCache) in d:\bt\932496\repo\src\dev\Common\Gateway\ConfigurationProvider.cs:108
Microsoft.Online.AggregatorService.Common.Gateway.GlobalContext.TryGetConfigurationItem(String identifier, TConfigItem&amp; item) in d:\bt\932496\repo\src\dev\Common\Gateway\GlobalContext.cs:324
Microsoft.Online.AggregatorService.Common.Gateway.GlobalContext.GetAgsRootConfig() in d:\bt\932496\repo\src\dev\Common\Gateway\GlobalContext.cs:276
Microsoft.Online.AggregatorService.Common.ThrottleClient.GetThrottleEndpoint() in d:\bt\932496\repo\src\dev\Common\Throttling\ThrottleClient.cs:577
Microsoft.Online.AggregatorService.Common.ThrottleClient.Initialize() in d:\bt\932496\repo\src\dev\Common\Throttling\ThrottleClient.cs:129
Microsoft.Online.AggregatorService.WebService.Global.Application_Start(Object sender, EventArgs e) in d:\bt\932496\repo\src\dev\WebService\Global.asax.cs:120

[HttpException (0x80004005): Object reference not set to an instance of an object.]
System.Web.HttpApplicationFactory.EnsureAppStartCalledForIntegratedMode(HttpContext context, HttpApplication app) +535
System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers) +166
System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context) +169
System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +372
System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext) +329

[HttpException (0x80004005): Object reference not set to an instance of an object.]
System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +525
System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +118
System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +708
</pre></code>

</td>
</tr>
</table>

<br>

<hr width=100% size=1 color=silver>

<b>Version Information:</b>&nbsp;Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.7.2623.0

</font>

</body>
</html>
<!--
[NullReferenceException]: Object reference not set to an instance of an object.
at Microsoft.Online.AggregatorService.Common.Gateway.AgsIndexConfigProvider.GetConfigVersionNumber(String configType, String configId) in d:\bt\932496\repo\src\dev\Common\Gateway\AgsIndexConfigProvider.cs:line 64
at Microsoft.Online.AggregatorService.Common.Gateway.ConfigurationProvider`1.GetConfigurationImp(String identifier, Boolean useCache) in d:\bt\932496\repo\src\dev\Common\Gateway\ConfigurationProvider.cs:line 389
at Microsoft.Online.AggregatorService.Common.Gateway.ConfigurationProvider`1.GetConfiguration(String identifier, Boolean useCache) in d:\bt\932496\repo\src\dev\Common\Gateway\ConfigurationProvider.cs:line 108
at Microsoft.Online.AggregatorService.Common.Gateway.GlobalContext.TryGetConfigurationItem[TConfigItem](String identifier, TConfigItem& item) in d:\bt\932496\repo\src\dev\Common\Gateway\GlobalContext.cs:line 324
at Microsoft.Online.AggregatorService.Common.Gateway.GlobalContext.GetAgsRootConfig() in d:\bt\932496\repo\src\dev\Common\Gateway\GlobalContext.cs:line 276
at Microsoft.Online.AggregatorService.Common.ThrottleClient.GetThrottleEndpoint() in d:\bt\932496\repo\src\dev\Common\Throttling\ThrottleClient.cs:line 577
at Microsoft.Online.AggregatorService.Common.ThrottleClient.Initialize() in d:\bt\932496\repo\src\dev\Common\Throttling\ThrottleClient.cs:line 129
at Microsoft.Online.AggregatorService.WebService.Global.Application_Start(Object sender, EventArgs e) in d:\bt\932496\repo\src\dev\WebService\Global.asax.cs:line 120
[HttpException]: Object reference not set to an instance of an object.
at System.Web.HttpApplicationFactory.EnsureAppStartCalledForIntegratedMode(HttpContext context, HttpApplication app)
at System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers)
at System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context)
at System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context)
at System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext)
[HttpException]: Object reference not set to an instance of an object.
at System.Web.HttpRuntime.FirstRequestInit(HttpContext context)
at System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context)
at System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context)
--><!--
This error page might contain sensitive information because ASP.NET is configured to show verbose error messages using &lt;customErrors mode="Off"/&gt;. Consider using &lt;customErrors mode="On"/&gt; or &lt;customErrors mode="RemoteOnly"/&gt; in production environments.-->

 

Has anyone else experienced this and have any suggestions as to what could be the problem? This app has not been modified for several weeks and users were in it yesterday with no issue at all.

 

Thanks!

1 REPLY 1
Highlighted
Helper V
Helper V

Re: Graph Custom Connector - Object not set to an instance of an object

Please share your json file here.

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Robotic Process Automation

Let's talk about the solution provided by Microsoft for Robotic Process Automation (RPA)

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

Top Solution Authors
Top Kudoed Authors
Users online (6,426)