cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
samuelJ
Responsive Resident
Responsive Resident

Grey screen never going away upon loading an app

Hi,

 

     We rolled an app out to ~30 people for UAT.  Upon having that group open the app, they could not get past the defualt PowerApps loading screen.  The screen I am reffering to, is the grey screen built into PowerApps that is shown when first loading into an app.  This is not a custom screen we made, this is shown by PowerApps when first clicking on an App.  

 

     Does anyone have any idea what I should troubleshoot first?  Db connection? User Error?

 

Thank you in advance!

12 REPLIES 12
samuelJ
Responsive Resident
Responsive Resident

Hello @mr-dang,

 

As I am fairly new to PowerApps, I did not know of this "Region" setting for an envirnment.  I created multiple instances of the app, one is U.S. and one in Asia.  So far no users in Asia have reported having this time out issue, and some were in hotels.  

 

As our app is ~60MB and was being hosted in the U.S. Region, I think people in Asia were experiencing being timed out when trying to download the app.  

 

Would this be a fair assumption?  For now, I don't think I will try the whitelisting of IP's as the Region change seems to have good feedback.

 

I greatly appreciate all the help and insight!

View solution in original post

mr-dang
Community Champion
Community Champion


@samuelJ wrote:

Hello @mr-dang,

 

As I am fairly new to PowerApps, I did not know of this "Region" setting for an envirnment.  I created multiple instances of the app, one is U.S. and one in Asia.  So far no users in Asia have reported having this time out issue, and some were in hotels.  

 

As our app is ~60MB and was being hosted in the U.S. Region, I think people in Asia were experiencing being timed out when trying to download the app.  

 

Would this be a fair assumption?  For now, I don't think I will try the whitelisting of IP's as the Region change seems to have good feedback.

 

I greatly appreciate all the help and insight!


Hi @samuelJ, that would be a fair assumption. Are you able to run a test and fully confirm that it's the location where the app is hosted that is causing you performance issues?

 

At 60MB that is a very large app. At most, one of my heaviest apps was 5MB, but I shrank it below 1MB by hosting images online. I think you can benefit greatly from this blog post on performance as well:

https://powerapps.microsoft.com/en-us/blog/performance-considerations-with-powerapps/

Microsoft Employee
@8bitclassroom
samuelJ
Responsive Resident
Responsive Resident

@mr-dang,

 

This is a rather large app, it has many images on it the app itself.  We originally tried to host the pictures in a DB, however there is a requirment to be able to see some data/pictures offline as well as online.  We tried the SaveData() and LoadData() functionallity, however that seems to not be able to cache any images, once going offline the text would all still be visible, but not images.

 

Now that our users are able to open the app without issue, we will probably look again into storing the images as blobs.

 

Again thank you for all your help. 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (2,339)