cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Continued Contributor
Continued Contributor

HELP - Azure Maps Connector - Bad Gateway - Invalid Parameter

Greetings,

We are in the throws of a hackathon and have run into an issue with the Azure Maps connector.  When we refer to location Concatenate(Location.Latitude & "," & Location.Longitude) using a concatenate "," we receive an error (shown in image).  However, if we hard code the lat/long with a value, 32.7555, 97.3308, we do not experience the issue and the feature provides the desired results.  For our purposes, we need to refer to the users lat/long.  

 

We also attempted:

  • Referencing the CHAR()
  • Placing the "," in a label and referring to the label
  • Everything else under the sun that we could think of......

image.png

@ericonline  

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted

Hi @tianaranjo 

Looking at this a bit more closely, it looks like your formula isn't picking up the long and lat values (just the ,).

image.png

Perhaps this might be some timing issue. Maybe you could try retrieving the your coordinates in the OnVisible of your screen and then try passing the variable to GetAddress?

 

View solution in original post

Highlighted

Not sure which of the two items below fixed it but here are the additional items we tried:

- Shared the Custom Connector with `Edit` permissions to everyone

- Moved the API call from OnVisible to a navigation button within the app (per @timl's "timing" recommendation)

- This one is really weird:

    - The GET request had a parameter that was misspelled ("long" instead of "lon")

    - Still, the Custom Connector pulled in (incorrect) Responses!

    - Even the Azure Maps API Docs pulled in (incorrect) Responses with the misspelling!

    - image.png

Hope this helps! Thanks for posting @tianaranjo 

View solution in original post

4 REPLIES 4
Highlighted
Super User III
Super User III

Hi @tianaranjo 

One issue is that Latitude and Longitude values are numeric, so you might want to try converting them to text like so:

 

Concatenate(Text(Location.Latitude) , 
"," ,
Text(Location.Longitude)
)
Highlighted
Continued Contributor
Continued Contributor

@timl Forgot to mention that we do have Text without success. Thanks!

Highlighted

Hi @tianaranjo 

Looking at this a bit more closely, it looks like your formula isn't picking up the long and lat values (just the ,).

image.png

Perhaps this might be some timing issue. Maybe you could try retrieving the your coordinates in the OnVisible of your screen and then try passing the variable to GetAddress?

 

View solution in original post

Highlighted

Not sure which of the two items below fixed it but here are the additional items we tried:

- Shared the Custom Connector with `Edit` permissions to everyone

- Moved the API call from OnVisible to a navigation button within the app (per @timl's "timing" recommendation)

- This one is really weird:

    - The GET request had a parameter that was misspelled ("long" instead of "lon")

    - Still, the Custom Connector pulled in (incorrect) Responses!

    - Even the Azure Maps API Docs pulled in (incorrect) Responses with the misspelling!

    - image.png

Hope this helps! Thanks for posting @tianaranjo 

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (12,546)