cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
meddlema
Helper I
Helper I

HTML Table with Send an eMail V2

Hello, 

 

I have a couple of Power Apps forms that collects information and when the user clicks the submit button it sends an email to the required people (it is not posted to SharePoint or anywhere else) and the body of the email has a formatted HTML table with the data.  I was able to successfully setup this up using Send an Email action and having it collect the data from the form.  The form has the To, CC and Body.  I used an HTML text box in the form that his hidden that has the data and html format. 

 

Screenshot of the submit button on the form 

Submit Button Format.png

 

and the flow is set to Ask in Powerapps (HTML is set to Yes)

New Hire Flow.png

and the output of the email body is formatted the way it should. 

 

With that said, my issue is in using the action Send an Email V2

 

They data is collected into the email but the HTML formatting is gone.  (ignore the /td> I can fix that)  

I am not sure how to collect and format the data now with Send an Email V2.

 

Term Email.png

 

Any help will be greatly appreciated. 

1 ACCEPTED SOLUTION

Accepted Solutions
mdevaney
Super User
Super User

@meddleam
I have two suggestions:

First, create a label in your PowerApps and put the code HtmlText1.HtmlText in the Text property. Does it show the expected HTML text? Perfect, if yes move on to suggestion #2.

In your Flow initialize a variable and set it to the the value of the HTMLText piece with a type String. Run the code and check that it comes in properly.

Also, it would likely help if you shared some of your HTML code. Let me know.

—-
Please Accept as Solution if this post answered your question so others may find it more quickly. If you found this post helpful consider giving it a Thumbs Up.

View solution in original post

2 REPLIES 2
mdevaney
Super User
Super User

@meddleam
I have two suggestions:

First, create a label in your PowerApps and put the code HtmlText1.HtmlText in the Text property. Does it show the expected HTML text? Perfect, if yes move on to suggestion #2.

In your Flow initialize a variable and set it to the the value of the HTMLText piece with a type String. Run the code and check that it comes in properly.

Also, it would likely help if you shared some of your HTML code. Let me know.

—-
Please Accept as Solution if this post answered your question so others may find it more quickly. If you found this post helpful consider giving it a Thumbs Up.

Apologies for the delay in response!   The HTML was incorrect.   I fixed that everything is working.  Thank you for the assist!!

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

365 EduCon 768x460.png

Microsoft 365 EduCon

Join us for two optional days of workshops and a 3-day conference, you can choose from over 130 sessions in multiple tracks and 25 workshops.

Users online (3,228)