cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
scottypotty4x4
Frequent Visitor

HTML code shows in body of email

I have a gallery that pulls from a SharePoint list.  The list was created from a large pre-existing excel spreadsheet.  One of the columns is HTML Text.  I want to send the value of this column in an email when a button is pressed but keep getting the HTML code wrapped around the value.

 

Button Code:

Office365Outlook.SendEmail(User().Email, 'Retailer Name' & " information", DataCardValue1.Text & Char(10) & HtmlText2.HtmlText)

 

Result:

Data from Card Value 1

<div>030301</div>

 

How do I get the email to remove the <div> and </div>?

 

Thanks, I'm a Power Apps newbie....

1 ACCEPTED SOLUTION

Accepted Solutions
PG_WorXz10
Resident Rockstar
Resident Rockstar

Hi @scottypotty4x4 ,

 

Please try the below code. 

Office365Outlook.SendEmail(User().Email, 'Retailer Name' & " information", DataCardValue1.Text & Char(10) & HtmlText2.HtmlText,{IsHtml:true})

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

If this post was helpful or you need more help please consider giving Thumbs Up and Tag me in your reply I'll be happy to help. If this post helped you solve your issue please click Accept as solution and provide Thumbs Up. This will help others find it more readily.

View solution in original post

3 REPLIES 3
PG_WorXz10
Resident Rockstar
Resident Rockstar

Hi @scottypotty4x4 ,

 

Please try the below code. 

Office365Outlook.SendEmail(User().Email, 'Retailer Name' & " information", DataCardValue1.Text & Char(10) & HtmlText2.HtmlText,{IsHtml:true})

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

If this post was helpful or you need more help please consider giving Thumbs Up and Tag me in your reply I'll be happy to help. If this post helped you solve your issue please click Accept as solution and provide Thumbs Up. This will help others find it more readily.

View solution in original post

scottypotty4x4
Frequent Visitor

It worked but now my carriage returns (Char(10)) no longer works.  Please advise

scottypotty4x4
Frequent Visitor

I was able to figure it out replacing Char(10) with <br>

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,931)