cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
white_knight
Frequent Visitor

HTML table formatting challenges - Post message to TEAMS channel

Hi all, I hope someone can help with a formatting issue that I can seem to resolve my looking at all the other posts and online material.

I have a excel table that I need to read and then post to a MS TEAMS channel if certain criteria are met. Its all working expect I cant get the table in the post to look very readable. I have tried using the CSS style approach but this appears not to work for a MS TEAMS post. I have there for resorted to using compose with the

replace(body('Create_HTML_table_2'),'<table>','<head><style>table, th, td {border: 1px solid black;border-collapse: collapse;}</style></head><table border="1">').
Below screenshots
Here is my table
white_knight_0-1658408842043.png

and this is what appears in my channel post

white_knight_1-1658408917349.png

As you can see there is no gap between the two columns of data. I have tried add spaces when using create HTML table as below

white_knight_2-1658409255654.png

Any suggests to get this table formatted so that the two columns are not so close most welcome.

 
 
 
 
7 REPLIES 7
abrae005
Kudo Collector
Kudo Collector

I would add some cell padding in your table.

<style>table, th, td {border: 1px solid black;border-collapse: collapse; padding:5px;}</style>

Hey, thanks for taking the time out to look at this. I did try your suggestion but it does not appear to have any impact.

Here is my new compose formula 

replace(body('Create_HTML_table_2_from_EODData_in_EOD_Report'),'<table>','<head><style>table, th, td {border: 5px solid black;border-collapse: collapse; padding:5px;}</style></head><table border="1">')

 

and the new screen shot

white_knight_0-1658413730570.png

 

abrae005
Kudo Collector
Kudo Collector

Ok. I did a quick test with one of my powerapps that generates emails, and I created a team in Teams to test. As it turns out, Teams ignores CSS formatting. So, the way we added the padding won't work.

 

Try this instead:

replace(body('Create_HTML_table_2_from_EODData_in_EOD_Report'),'<table>','<head><style>table, th, td {border: 5px solid black;border-collapse: collapse; }</style></head><table border="1" cellpadding="5px">'

 

mmm... all very odd. I tried what you suggested, thanks, and also added cellspacing but still having zero impact  😭When I look at the flow history after that run for the post message I see the following in the Inputs

Message

<p><strong></strong><strong>2</strong><strong> Business Exceptions<br>
</strong><strong>6</strong><strong> System Exceptions</strong><br><br>
<p>
<table border="1" cellspacing="10" cellpadding="5px"><thead><tr><th>RFS/PCR</th><th>Reason</th></tr></thead><tbody><tr><td>LGTE-REQ-000065 </td><td> System Exception: SE: NV - Open Existing RFS Record - Could Not Find Workflow Status Table Label</td></tr><tr><td>LRCS-PCR-000315 </td><td> Business Exception: BE: 1. Update RFS Sharepoint - RFS Record Already Exists</td></tr><tr><td>LTRP-REQ-001079 </td><td> System Exception: SE: I - Download Attachment - Unable to find save as button</td></tr><tr><td>LIPC-REQ-000155 </td><td> System Exception: SE: I - Download Attachment - Unable to find save as button</td></tr><tr><td>LGTE-REQ-000065 </td><td> System Exception: SE: NV - Open Existing RFS Record - Could Not Find Workflow Status Table Label</td></tr><tr><td>LRCS-PCR-000315 </td><td> Business Exception: BE: 1. Update RFS Sharepoint - RFS Record Already Exists</td></tr><tr><td>LTRP-REQ-001079 </td><td> System Exception: SE: I - Download Attachment - Unable to find save as button</td></tr><tr><td>LIPC-REQ-000155 </td><td> System Exception: SE: I - Download Attachment - Unable to find save as button</td></tr></tbody></table><br>
</p>

As you can see my concat is working as there are spaces there.

 

But end up with

white_knight_0-1658420569142.png

I am being to think I might have to rethink this 🤔

 

abrae005
Kudo Collector
Kudo Collector

HTML will (and always has) ignored extra spaces. You need to use 

&nbsp;

in the HTML code instead of an extra space after your TD tag. But, before you go changing all of that, try the suggestion below.

 

Unfortunately, Teams doesn't fully support CSS, and adding attributes in straight HTML isn't really recommended anymore.

 

One other thing to try, and this is my fault for using the wrong HTML ... instead of cellpadding="5px" try just "5" ... and try changing it to a larger value, like 15. Let me know if that works.

Hey, I really apricate you trying to help me here as almost all of the articles I've found talk about CSS but as you and I have found they are not supported in MS Teams.

 

I've tried the syntax change you mentioned and increased the value but again it appears that MS TEAMS is ignoring any attempt to change this. The only value that appears to have an effect is the the border="1".

 

So I have tried to use the &nbsp; but not sure I have the syntax correct as those characters are being displayed see below picture. I am using concat('&nbsp;',item()?['Exception Reason'])

I did try without quotes around &nbsp; but that generates an error so I used "_" , second screenshot. Its not pretty but it is a little more readable.

If you can correct my syntax when trying to add &nbsp that would be awesome 

 

white_knight_0-1658493233057.png

white_knight_1-1658493573427.png

 

 

abrae005
Kudo Collector
Kudo Collector

Ok, that's odd ... My tests were with just copying the HTML into an email and sending it to the channel's email address, and it seemed to work.

 

Then I copied the same HTML code and put it into a Power Automate flow - once with a "Post to Teams" action, and once with a "Email" action, and it didn't work.

 

Here's a screenshot from yesterday when I was just emailing to the team using Outlook.

abrae005_1-1658494948905.png

And here's the samples from this morning when I put it into a Power Automate Flow:

abrae005_2-1658494990157.png

 

So, something about the process Power Automate is using to parse the HTML is causing it to break, even though the code is correct, and even when I review the outputs, it still has the Cellpadding in there.

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Top Solution Authors
Top Kudoed Authors
Users online (1,471)