cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
lyndenswift
New Member

Help Desk Template

Hi there,

I am just learning Power Apps and am following along a Udacity course. I have tried to create my first app using the Help Desk template. However, when I get to the window for allowing permissions, it asks me to sign in.

Q1: Do I sign in here with my onmicrosoft account or just my microsoft account?

Q2: regardless of which account I sign in with, it just gives me an error message of : "We weren't able to add this connection. Please try again. One of more of your connections may not be authenticated. Please go to the connections menu to fix them".

 

I don't really know what this means. If I go back to the Power Apps portal, under Data there is a connections tab. That just has a button to 'create a connection' but when I click on that it brings up a whole page of options. I have no idea what I am supposed to click on.

 

Can anyone explain what is happening here and how  I get around it? Apologies if this is a really low level question, it probably is, but this is the first PA I am trying to build and am running into confusing errors already.

 

Thank you in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
timl
Super User
Super User

Hi @lyndenswift 

The help desk template app uses the Office365Users connector. Therefore, it would be the onmicrosoft account that you would use.

I would try to login again using the in-private/incognito mode of your browser and to try creating your app again using the template. This can often clear authentication problems, particularly if you've been attempting to logon using different accounts.

If that fails, I would create a blank app from scratch and I would try adding a connection to Office365Users through the Data > Add data menu item. This will enable you to diagnose whether your account is actually able to access the Office365Users data source. Note that this data item will be missing from the template app.

timl_0-1615375339096.png

 

 

View solution in original post

2 REPLIES 2
timl
Super User
Super User

Hi @lyndenswift 

The help desk template app uses the Office365Users connector. Therefore, it would be the onmicrosoft account that you would use.

I would try to login again using the in-private/incognito mode of your browser and to try creating your app again using the template. This can often clear authentication problems, particularly if you've been attempting to logon using different accounts.

If that fails, I would create a blank app from scratch and I would try adding a connection to Office365Users through the Data > Add data menu item. This will enable you to diagnose whether your account is actually able to access the Office365Users data source. Note that this data item will be missing from the template app.

timl_0-1615375339096.png

 

 

View solution in original post

Hi Timl, this has worked.

My sidebar icons are not the same as yours but scrolling down and down and down I finally found the Office 365 users icon and added that. It still wouldn't work so I then opened a private browser window and, really bizarrely, that worked. It now works when i log in normally as well, which is good.

 

Thank you for your help - this was really confusing.

Helpful resources

Announcements
2022 Release Wave 1 760x460.png

2022 Release Wave 1 Plan

Power Platform release plan for the 2022 release wave 1 describes all new features releasing from April 2022 through September 2022.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Solution Authors
Top Kudoed Authors
Users online (2,564)