cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
TDeWitt
Regular Visitor

Help with text fields autopopulating from a secondary data source

I have created an app based off of a list from Teams. One of the text inputs is requesting a number that matches a second connected data source. I would like additional fields requested on the list to autopopulate with information pulled from the second data source. How can i do this?

1 ACCEPTED SOLUTION

Accepted Solutions

I believe the problem is the comparison should be DOCNUM=DataCardValue15.Text

Not sure if the Quotes are needed or not, but you need to specify the property of the Data Card you are comparing.

View solution in original post

9 REPLIES 9
BrianS
Super User
Super User

You can use Lookup to find the data from the second source. Since you are using Dataverse, you can also create a link there between the 2 tables which will allow easier access, but it does require the extra set-up.

the documentation for Lookup is here

The syntax for using the connected Dataverse tables is a little unusual. Shane Young did a good overview here

Once you get the data you can use it to populate the Default values of the other fields.

TDeWitt
Regular Visitor

LookUp(Table2, DOCNUM='DataCardValue15',BEDCODE)

 

here is the syntax i am using. I am trying to have this box autopopulate information from "table 2" based off of the information entered into the field "DataCardValue15". 

I believe the problem is the comparison should be DOCNUM=DataCardValue15.Text

Not sure if the Quotes are needed or not, but you need to specify the property of the Data Card you are comparing.

TDeWitt
Regular Visitor

I made this adjustment, but the field is still not populating the information from the second data set. There is no error, but the information just isnt filling the textbox

BrianS
Super User
Super User

If you highlight juts the "DOCNUM=DataCardValue15.Text" portion of the formula do you get a value returned by the system in the area just under the formula window?

TDeWitt
Regular Visitor

no, there is nothing that shows up under the formula window

BrianS
Super User
Super User

It is working when I try it on my end:

BrianS_0-1635356398642.png

Are you sure that there is data to match the text in your initial datacard?

TDeWitt
Regular Visitor

It is working now! all i did was refresh the data source. Thank you so much for your time!

BrianS
Super User
Super User

Glad to hear it!

Helpful resources

Announcements
PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Top Solution Authors
Top Kudoed Authors
Users online (1,978)