cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Horizontal gallery's navigation buttons don't work unless you scroll to the second item

Hi,

 

I'm having this issue with the horizontal gallery control wherein the navigation buttons don't work unless I move to the second item first using the scrollbar. Once the second item is selected, then the buttons start working.

 

Has anyone else encountered this?  Is there a fix for it?

 

Thanks.

24 REPLIES 24
Highlighted
Super User III
Super User III

@datatech 

Not seeing that here...

You are referring to the "Show Navigation" option in the gallery control being enabled.

 

Just ran a quick check.  Put in gallery, turned on Navigation.  It appeared to work just fine.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up. Solved your problem? - Click on Accept as Solution. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too!
Highlighted

Hi Randy,

Sorry, didn't make it clear.

Yes, I'm referring to ShowNavigation property. It works while in Edit mode but not when you play the app mode in the web browser.

I have two horizontal galleries in my app and they both have the same behaviour. First time you play the app, the nav buttons don't work and you need to scroll to the next item first then the buttons will work.
Highlighted

HI @datatech ,

Could you please share a bit more about your scenario?

Which browser do you use to run your canvas app?

I have made a test on my side, and don't have the issue that you mentioned.

 

Please take a try to run your app within other browsers, then check if the issue still exists.

 

Please consider take a try to turn off/disable the "Improved app rendering (final validation)" option within Advanced settings of App settings of your app, then re-publish your app, check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted

Hi Kris,

 

This happens in Edge, Chrome, Firefox and Opera.

 

I've disabled "Improved app rendering (final validation)" but it made no difference.

 

I'll do some more tests and see if I can provide more details.

 

horizontal gallery.gif

Highlighted

Hi Kris,

 

It seems to be a bug.

 

Here's what I did.  I created a new blank app and added two new galleries - 1 horizontal (Gallery1) and 1 vertical (Gallery2).  I've set up Gallery1 to use a SharePoint list for its items and left Gallery2 with "CustomGallerySample" for its items. Saved and published.

 

Result1:  Gallery1 had the issue while Gallery2 didn't have it.

Next, I changed the Items of Gallery2 to another SharePoint list, saved and published.

Result2:  Both galleries are now having the same issue.

Highlighted

Hi @v-xida-msft ,

 

Were you able to replicate this issue?

 

Thanks.

Highlighted
Frequent Visitor

Hi, am I the only one having this issue or is it actually a bug?

Highlighted

This bug is frustrating.  Anyone who's reading this, please take note that ShowNavigation does not work on horizontal galleries.

 

It seems to work while you're still working on the app but once you publish it, it won't. 

 

Don't use a horizontal gallery in your UI, you'll just be wasting your time.

 

To think I pay for this garbage is infuriating.

Highlighted
Anonymous
Not applicable

Hi @datatech I wasn't able to find similar cases in the community however I'm going to bump this in the hopes other users can assist. 

 

@Anonymous 

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (8,075)