cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
datatech
Frequent Visitor

Horizontal gallery's navigation buttons don't work unless you scroll to the second item

Hi,

 

I'm having this issue with the horizontal gallery control wherein the navigation buttons don't work unless I move to the second item first using the scrollbar. Once the second item is selected, then the buttons start working.

 

Has anyone else encountered this?  Is there a fix for it?

 

Thanks.

25 REPLIES 25

Thanks @Anonymous  but are you able to replicate the issue based on the steps I've provided?

 

Running it while in the editor will not exhibit the issue.  It needs to be run as a published app - Play the app don't Edit it. 

MrsNaniPenny
Advocate I
Advocate I

I am also having the same issue. 

 

Scenario:

I have a horizontal gallery. The gallery "card" takes up all the space on the screen, so only 1 item is showed at a time. Scrollbar is disabled, Show Navigation option is enabled. On the first item the first time, the nav buttons don't work. If I then "scroll" with my keyboard arrows and the second item is displayed (even just a little bit), then the nav buttons start to work.

Hi @datatech ,

 

Maybe try a different browser? 

 

Thanks, 

Luke

Hi @Luke_Timmins , it happens in all browsers.

Hi @datatech,

 

I had the same issue. My navigation controls would not work until I scrolled to the second item, after which they would work as normal. However they would only work for a few clicks, and then would mysteriously stop working. 

 

I was able to fix the issue by changing the Navigation Step option to 2 instead of 1. Strangely, you would expect the navigation buttons to jump two items at a time, but it seems to be random, sometimes navigating by one item and sometimes by two.

 

Not a perfect solution, but maybe it can help you.

I'm having the same issue - horizontal gallery navigation works when editing the app in PowerApps. When you embed it in a SharePoint site - it fails.

 

If you can even supply a best practice solution for moving between records using manual buttons that would be great.

I too am facing the same issue

I am facing exactly the same issue as reported by @datatech

same problem here. This post is now over 1 year old and its still not working...

I have the same issue with a vertical gallery as well, and increasing the navigation step to 2 fixes the issue

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Top Kudoed Authors
Users online (1,155)