cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Future_Vision
Post Prodigy
Post Prodigy

How do I fix and Error loading control error?

Last week I noticed that two of my comboboxes started having issues loading as seen in the image below. At first i thought it had to do with the Power Apps release number. I noticed the issues with 3.21054.36. I rolled back to a previous version, 3.21053.21, and everything seemed to be fine. I load up the app today, still on 3.21053.21, and the comboboxes are failing to load again.

 

Future_Vision_0-1623681361610.png

 

A couple things to note about these comboboxes.

  1. They have their own datasources
  2. Each gets refreshed when a value is submitted(patched) to the datasource via a text input

The only thing that has changed recently is that the button for the text input got a bit of an upgrade. When the button clicks it now checks to see if the value is a duplicate and if it finds a duplicate there is an notify message and the background color of the text box changes color. It also sends a Teams message when the new value is added. I fail how to see this is relevant to the combobox.

 

Any ideas what else I should look at to debug this?

1 ACCEPTED SOLUTION

Accepted Solutions
Future_Vision
Post Prodigy
Post Prodigy

Yes. I see what is happening. If I click the "Add" button with no value in the text input it enters a blank record. Previously it would not input anything if there was no value in the text input. Looks like a simple change from IsBlank to !IsBlank.

View solution in original post

4 REPLIES 4
Future_Vision
Post Prodigy
Post Prodigy

Oh wow. I think I may have found the issue. Somehow I had some blank entries in my datasource. That seems to imply that whatever I am doing with the text input field and button is putting blank entries into the datasource.....I think.

Future_Vision
Post Prodigy
Post Prodigy

Yes. I see what is happening. If I click the "Add" button with no value in the text input it enters a blank record. Previously it would not input anything if there was no value in the text input. Looks like a simple change from IsBlank to !IsBlank.

View solution in original post

Hi,

 

Thanks for your follow up post! I am glad that you were able to get this figured out. Hopefully this will prove useful for future communities users.

 

Regards,

 

Alex

 

-------

 

Community Support Team _ Alex Rezac
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Future_Vision
Post Prodigy
Post Prodigy

Would be nice if there was some indication of what was going on. Fortunately I found another post that gave me a clue what the issue was.

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Demo Extravaganza Winner Announcement

Please join us on Wednesday, July 21st at 8a PDT. We will be announcing the Winners of the Demo Extravaganza!

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Top Kudoed Authors
Users online (2,582)