cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mohamedmerrouch
Frequent Visitor

I can't add new connections/connectors anymore [Office 365 Outlook, Office 365 Users ...]

Hello Everyone,

 

While working with the PowerApps ad following the learning paths for 2 days. I can't add new connections anymore. I am only stuck with the already set connections from the first moment I started using it (a Sharepoint Connector and OneDrive as mentioned in the screenshots). I keep getting the following errors (found in screenshots too):

 

"Error from token exchange: Runtime call was blocked because connection has error status: Enabled| Error, and office365 is in the block list. Connection errors: [ParameterName: token, Error: Code: Unauthenticated, Message: 'This connection is not authenticated.']"

 

I tried the following to troubleshoot in vain:

  • I tried adding connections from both the studio and the powerapps portal and connections tab (as showed in screenshots)
  • I tried to sign out and close all tabs and relaunch the app
  • I tried to revoke the permissions related to powerapps that I found in the office 365 account parameters
  • I tried many connectors unrelated to office: Dropbox worked but Gmail didn't (check screenshots)
  • I tried to do it from another app but no results

Thank you in advance for your help !

@mdevaney 

1 ACCEPTED SOLUTION

Accepted Solutions

Hello @v-monli-msft 

 

First thank you for taking the time to reply. After trying everything including what you just suggested, I opened a ticket with Microsoft Support. The issue is in their back-end. The authentication process in PowerApps times out after many uses and it is no more able to sign in with your account to add new connections. The issue is worked on by the Microsoft developer team. However, there is a temporary solution, one should go first through Microsoft flow and add flows that uses the connectors needed in PowerApps and sign in there in Flow. The authentication process in flow is stable so it works. And then we you go back to powerapps and try to add your connectors you find an already established and signed in connection with the services such outlook or office users and you can then successfully add it with no issues.

 

This issue got me frustrated for 2 days now as I was trying to troubleshoot it everyday. But this temporary solution suggested by the support team helped. In hopes that the real issue will be fixed soon.

 

I hope this post will be of a help to anyone facing the same issue out there. I don't want others to go through the same frustration hahaha.

 

Thank you again @v-monli-msft  and have a good day !

View solution in original post

5 REPLIES 5
v-monli-msft
Community Support
Community Support

Hi @mohamedmerrouch ,

 

Have you tried with different web browsers? Are you able to add data sources within app?

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hello @v-monli-msft 

 

First thank you for taking the time to reply. After trying everything including what you just suggested, I opened a ticket with Microsoft Support. The issue is in their back-end. The authentication process in PowerApps times out after many uses and it is no more able to sign in with your account to add new connections. The issue is worked on by the Microsoft developer team. However, there is a temporary solution, one should go first through Microsoft flow and add flows that uses the connectors needed in PowerApps and sign in there in Flow. The authentication process in flow is stable so it works. And then we you go back to powerapps and try to add your connectors you find an already established and signed in connection with the services such outlook or office users and you can then successfully add it with no issues.

 

This issue got me frustrated for 2 days now as I was trying to troubleshoot it everyday. But this temporary solution suggested by the support team helped. In hopes that the real issue will be fixed soon.

 

I hope this post will be of a help to anyone facing the same issue out there. I don't want others to go through the same frustration hahaha.

 

Thank you again @v-monli-msft  and have a good day !

Hi All,

 

I tried with the solution mentioned but still getting the below error in Power Automate.

Office 365 Error.png

@mohamedmerrouch @v-monli-msft 

 

Thanks

I am able to add the connector from Flow however that is for myself... in PowerApps each user of the app would need to do this before they use the app for the first time. Would appreciate a fix from Microsoft on this!

hnoorebad
Frequent Visitor

It is annoying all new users have problem with connections, I have managed to add other connections using the flow URL:

https://australia.flow.microsoft.com/manage/environments/[Environment ID]/connections, but there is still problem with outlook connection:

 

 2020-01-14 10_55_35-Window.png

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power Platform Call June 2022 768x460.png

Power Platform Community Call

Join us for the next call on June 15, 2022 at 8am PDT.

PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

PA.JPG

New Release Planning Portal (Preview)

Check out our new release planning portal, an interactive way to plan and prepare for upcoming features in Power Platform.

Top Solution Authors
Top Kudoed Authors
Users online (1,599)