cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Yruiz
Frequent Visitor

I not have permissions to use any request

I have a dynamics trial, in which I have created a CanvasApp wich connects to custom entities and system entities: teams, users, etc. The issue is that the CanvasApp is already created and working perfectly until today. When i open it today in editor mode, all wueries, filters, searchs, etc, give me the same error: "You do not have permissions to use this search. server response: Access denied for resource: http://url of trial"

 

I connect with an administrator user and the one created on the Canvas. This user also has licenses of E3, powerApps plan 2, flow, etc.

 

Can anynone help me with this problem please?

1 ACCEPTED SOLUTION

Accepted Solutions
Yruiz
Frequent Visitor

Re: I not have permissions to use any request

This issue was not resolved. What i did was export and import the application again and all connections have been restored. I dont think this is the best solution but being just demo...

View solution in original post

4 REPLIES 4
Highlighted
DavidJennaway Responsive Resident
Responsive Resident

Re: I not have permissions to use any request

It may be that the trial has expired. Can you connect directly to the Dynamics instance via the browser - it this fails it should give a more useful error than the one you get from the Canvas App

nando1 Advocate I
Advocate I

Re: I not have permissions to use any request

Hi, 

I got the same probem. If I refresh the Datasources it works in edit mode for me. When playing the app it doesn't work either.

Greetings

Nando

 

Yruiz
Frequent Visitor

Re: I not have permissions to use any request

My trial only has 5 days of use, and i just verified that it has not expired. I have been investigating and it is a problem with the CDS connector, we have customers using the CDS connector with flow in production and it is giving exactly the same problem with the same error message  

Yruiz
Frequent Visitor

Re: I not have permissions to use any request

This issue was not resolved. What i did was export and import the application again and all connections have been restored. I dont think this is the best solution but being just demo...

View solution in original post

Helpful resources

Announcements
MBAS Gallery 2020

MBAS Gallery 2020

Watch Microsoft Business Applications Summit sessions on-demand.

firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Apps Community!

Top Solution Authors
Top Kudoed Authors
Users online (8,421)