cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

I not have permissions to use any request

I have a dynamics trial, in which I have created a CanvasApp wich connects to custom entities and system entities: teams, users, etc. The issue is that the CanvasApp is already created and working perfectly until today. When i open it today in editor mode, all wueries, filters, searchs, etc, give me the same error: "You do not have permissions to use this search. server response: Access denied for resource: http://url of trial"

 

I connect with an administrator user and the one created on the Canvas. This user also has licenses of E3, powerApps plan 2, flow, etc.

 

Can anynone help me with this problem please?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Frequent Visitor

Re: I not have permissions to use any request

This issue was not resolved. What i did was export and import the application again and all connections have been restored. I dont think this is the best solution but being just demo...

View solution in original post

4 REPLIES 4
Highlighted
Solution Supplier
Solution Supplier

Re: I not have permissions to use any request

It may be that the trial has expired. Can you connect directly to the Dynamics instance via the browser - it this fails it should give a more useful error than the one you get from the Canvas App

Highlighted
Advocate I
Advocate I

Re: I not have permissions to use any request

Hi, 

I got the same probem. If I refresh the Datasources it works in edit mode for me. When playing the app it doesn't work either.

Greetings

Nando

 

Frequent Visitor

Re: I not have permissions to use any request

My trial only has 5 days of use, and i just verified that it has not expired. I have been investigating and it is a problem with the CDS connector, we have customers using the CDS connector with flow in production and it is giving exactly the same problem with the same error message  

Highlighted
Frequent Visitor

Re: I not have permissions to use any request

This issue was not resolved. What i did was export and import the application again and all connections have been restored. I dont think this is the best solution but being just demo...

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Tech Marathon

Maratón de Soluciones de Negocio Microsoft

Una semana de contenido con +100 sesiones educativas, consultorios, +10 workshops Premium, Hackaton, EXPO, Networking Hall y mucho más!

Top Solution Authors
Top Kudoed Authors
Users online (7,002)