cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
R3dKap
Level 10

ISSUE - Components not showing values from global variables

Hi all,

Since last week (I think), if you bind a component custom parameter's value to a global variable, the value is not visible inside the component.

I have created a simple component with one custom text parameter. This component just shows the value of the parameter using a label control.

When I put the component on a screen, I see the following behavior:

  • if I set the parameter to "FIXED VALUE", the component shows "FIXED VALUE"
  • if I set the parameter to a local variable locVariable which is set in the OnVisible event of the screen using UpdateContext({locVariable: "LOCAL VALUE"}), the component shows "LOCAL VALUE"
  • if I set the parameter to a global variable gloVariable which is set in the OnStart event of the application or in the OnVisible event of the screen using Set(gloVariable; "GLOBAL VALUE"), the component shows nothing

Be aware that in this last case, if your global variable gloVariable was already set BEFORE you set the component's parameter to gloVariable, the component shows the correct value. But then, changing the value of the gloVariable will make the component to show nothing anymore.

Here is a test I made on my tenant (I've tested it on other tenants as well and other people have the same issue):

bc01.gif

If no one has posted a ticket to the Power Apps team yet, I'll do it...

IMPORTANT NOTE: publishing the app does not solve the problem!!

Emmanuel

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Super User
Super User

Re: ISSUE - Components not showing values from global variables

Hi @R3dKap 

 

This has been raised to the team already and the issue is being tracked 😺

 

Cheers,

Sancho




Don't forget to 'Mark as Solution' if a post answered your question and always 'Thumbs Up' the posts you like or helped you!

View solution in original post

3 REPLIES 3
Highlighted
Super User
Super User

Re: ISSUE - Components not showing values from global variables

Hi @R3dKap 

 

This has been raised to the team already and the issue is being tracked 😺

 

Cheers,

Sancho




Don't forget to 'Mark as Solution' if a post answered your question and always 'Thumbs Up' the posts you like or helped you!

View solution in original post

kbilakanti
Level 8

Re: ISSUE - Components not showing values from global variables

I am also facing the same issue. I have raised it with Microsoft. Waiting for their response
R3dKap
Level 10

Re: ISSUE - Components not showing values from global variables

This issue has been fixed! Thanks Power Apps Team!

Helpful resources

Announcements
Better Together’ Contest Finalists Announced!

'Better Together’ Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Join THE global Microsoft Power Platform event series

Attend for two days of expert-led learning and innovation on topics like AI and Analytics, powered by Dynamic Communities

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

thirdimage

Microsoft Business Applications Virtual Launch

Join us for the Microsoft Business Applications Virtual Launch Event on Thursday, April 2, 2020, at 8:00 AM PST.

thirdimage

Community Summit North America

Innovate, Collaborate, Grow - The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Top Kudoed Authors
Users online (10,565)