cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Id renamed to 'Id (ID)' in lists used in PowerApps results in SharePointIntegration.SelectedHidden error

Hi everyone,


I had to change a SharePoint list PowerApps form that I didn't modified in a while. When I opened the form I got several errors on the 'Id' column for multiple lists. For example in a Lookup(List, Id = 123) function. It appeared that all these columns had to be renamed in 'Id (ID)'.
So far so good, but in the end there were still remaining 2 errors:
- The name is invalid. This id isn't recognized
- Invalid argumenttype
These 2 errors come from the location "SharePointIntegration.SelectedHidden". When you click on it you are redirected to the "Datasource" field where you haven't anything like "SharePointIntegration.SelectedHidden".

I googled a bit and this braught me to this post:
https://powerusers.microsoft.com/t5/Building-Power-Apps/fix-an-error-in-SharePointIntegration-Select...

The people overthere have also problems with the SharePointIntegration.SelectedHidden faults. But there the problem is that an old list reference is in the .msapp file.
In this .msapp file you have a file with the following in it:

{
"Property": "SelectedHidden",
"Category": "Data",
"InvariantScript": "LookUp('Opstart audit', Id = SharePointIntegration.SelectedListItemID)",
"RuleProviderType": "Unknown"
},

As you can see there is a hidden lookup that you can't see in the PowerApps interface. The Id in the lookup is still the old value and not 'Id (ID)' as it should be according to PowerApps. So i thought to change this to 'Id (ID)' and follow the steps from the post I mentioned above. Everything seems fine, except when I open the app again after I imported him, the "OnCancel", "OnEdit", "OnNew", "OnSave", "OnView" actions are gone. I tried several times changing the value and upload it again to PowerApps, but nothing worked.

So my actual question is:
- Does anyone know about Id being renamed to 'Id (ID)' in PowerApps for SharePoint lists?
- Can I do something about this Id, so that I can still use the standard Id column instead of 'Id (ID)'?
- If Id renamed to 'Id (ID-)' is expected behaviour, how can I solve this? The method that I described above following the blog post doesn't work.

Thanks in advance for any advice!

P.S. I have the above issue on more then 1 list with PowerApps integrated form!




12 REPLIES 12
Frequent Visitor

Hello @Mistaah_G ,

 

Try to Refresh(Click on the ellipsis next to refresh) the SPList from the DataSources panel on the screen left side and go to the form properties on the right side and check if all fields are fields are correct.

Let me know if this helps

Hi @Silvester,

Refreshing the datasource doesn't work.
The PowerApp is a SharePoint integrated list PowerApp. The selectedHidden fault I get comes from the "Datasource" field in the "SharePointIntegration" tab.
The form that uses the datasource didn't contain the ID field, but if I add it, I get the same fault for that field, I have to rename 'Id' to 'Id (ID)'.

Kind regards,
G

Hi @Silvester ,


Yes, I did mention this in my original post, no solution for me...
My PowerApp gets broken with it (no more OnNew, OnEdit,... actions)

Frequent Visitor

@sergelucaExcuse me to tag you here, but do you know anything about this to help me with this issue?

Kind regards,
G
(we met at European SharePoint conference in Prague last year, I attended your session about PowerAutomate, I'm from Belgium to)

Regular Visitor

I've got this problem too, but after I've edited 1.json inside *.msapp file and did import edited package the app has SharepointIntegration missing from app components list. Any ideas on how to fix this problem?
Also, I can't re-create the app, because whenever I try to do this it says that app with such name already exists but if I click edit in sp list - default SharePoint form is displayed.

To recreate the app, you have to first delete the app and then import the package again or start from scratch.
Starting from scratch is is no option for me, I have 3 PowerApps with complex logic in it that required many days of development.
Think I'm going to open a Microsoft support ticket.

I have such error even if I delete it. 
I also have complex form that would take ages to re-create and I'd like to fix this problem, if possible, without re-creating whole app.

Advocate II
Advocate II

I have exactly the same issue on a few SharePoint lists. Must be many more users out there with this problem. The forms have quite complex logic in them and I don't feel like recreating them from scratch. The forms still work for creating new items, but when you open an existing item it will not show that item but the first item in the list. Problem started in June, and I did not find any solution yet. Your post is the first one I could find mentioning this problem, so this makes me already feel less lonely 😉

Helpful resources

Announcements
News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

Power Apps Community Call

Power Apps Community Call- January

Mark your calendars and join us for the next Power Apps Community Call on January 20th, 8a PST

PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

Top Solution Authors
Top Kudoed Authors
Users online (7,618)