cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
dettek
Frequent Visitor

Image column from my SharePoint list in PowerApp form?

Hi there.

 

I'm trying to create a power app form where end users can input images (which eventually goes through some flows to display in a paginated report). I'm struggling with the use of the "Image" column in sharepoint. When I add the column in Sharepoint it doesn't show up as an available field in PowerApps for me to add into my form. I've searched online but couldn't find a usable solution. Does anyone have any pointers? Appreciate any help!

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
dettek
Frequent Visitor
18 REPLIES 18
Pstork1
Dual Super User
Dual Super User

The image column was a newer addition to SharePoint online and isn't supported by the SharePoint connector. Workarounds include storing the image as BAse64 text in a text column or saving it to a library and storing a hyperlink to the image in the list.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Thanks for the workarounds! 

NotAnApe
New Member

Sounds like you will have an easier way by the end of the year, with the addition of Lists image controls for Power Apps: MC257468 - Power Apps can now display images from Microsoft Lists - The Unofficial M365 Changelog (m...

ahmednaseem
Helper I
Helper I

This has been in the development for almost a year and keeps changing the GA date every month. Can't rely on this feature for now, but there are other work arounds.

ganeshsanap
Memorable Member
Memorable Member

Power Apps can now display images from SharePoint Online/Microsoft Lists. This feature has started rolling out to Power Apps preview environments now. Check more details at:  Power Apps can now display images from SharePoint Online/Microsoft Lists 


Please click Accept as solution & ‌‌👍 if my answer helped you to solve your issue. This will help others to find the correct solution easily. If the answer was useful in other ways, please consider giving it ‌‌👍

 

Best Regards,

Ganesh Sanap

Blog site 

Now you can add and use a SharePoint picture field in a Power Apps app. And the image appear when you use the app on phone!

This il due to a roll up of the graph API from 12 march to 31 march. Maybe you must update your Power Apps environnement to benefit.

Hello @ganeshsanap ,

 

it doesn't work actually.

I used the picture column and even the command in powerapps is listed, but it doesn't show the image.

Picture column:

DeeJaWuecom_0-1649691051422.png

Powerapps Gallery:

DeeJaWuecom_1-1649691090863.png

Also the other options like full or small won't working.

 

Is there a mistake?

 

I also tried it with the old solution with Hyperlink column to a document library. This one works, but its not what i want to use...

 

Thanks for your help!

Are you using an established connection or a new connection?  It might just be relying on old code.  Its working for me as you can see from the screenshot below

image.png



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
DeeJaWuecom
Frequent Visitor

##Update 2: See below.

 

## Update 1: I got myself a coffee and now, the images shows up. So now it only needs about 2-3 minutes, after using it the first time.

Now i will try it in my existing app. Update follows!

 

I just made a new Test App in another Environment, but with the same result.

So, its a new clean canvas app, new connection,...

 

I have no Idea.

DeeJaWuecom_0-1649747950931.png

 

Update 2:
The difference is, that the Test app is only a normal canvas app, directly connected with sharepoint list.

The normal App is inside a Solution and works with environment variables.

 

When i made a Collect() inside both apps and let me show the URL to the pictures in a normal text field, i see some differences.

Thats the text:

DeeJaWuecom_1-1649749266398.png

 

And here are both URLs. The difference is highlighted.

 

DeeJaWuecom_2-1649749541558.png

 

I think, that's the problem, because it's the only difference i see at the moment.

Helpful resources

Announcements
Power Apps News & Annoucements carousel

Power Apps News & Announcements

Keep up to date with current events and community announcements in the Power Apps community.

Power Apps Community Blog Carousel

Power Apps Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (4,778)