cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
TimRohr
Solution Sage
Solution Sage

Image cuts off (in both Forms and Galleries) after uploaded...

I have an App utilizing a few Common Data Service entities: Regions, Groups, Employees, and Profiles. They relate as...

 

Regions {1:N} Groups {1:N} Profiles {N:1} Employees

 

Each Region, Group, and Employee has an Image field as a part of the entity, which becomes the EntityImage. I have my App setup to allow the user to choose an image to attach to any record in those entity tables.


When I first upload an image, it displays properly on the "Edit" Form. However, when I commit the change and get returned to my "Detail" form (or go to look for that record in a Gallery), the image is cut off, top and bottom.

 

And, yes, I have the ImagePosition property set to "Fit."

 

It doesn't matter how I resize the image control, nor what I set the ImagePosition property to be.

 

The images I have been uploading are sized to be 540 x 700 pixels. The image controls in a vertical gallery are 128 x 128, and in a Detail Form Data Card are 145 x 160. My understanding of the "Fit" setting for the ImagePosition property is that it should fit the image in the control size as defined, but you can see from the file I'm attaching that the top and bottom are being cut off.

 

Repeating the upload/attach process does nothing. The pic shows as full and complete in the control where I upload it, but then gets cut off in the galleries or forms.

 

Is there a setting that I am missing, or a workaround I am not aware of?

3 REPLIES 3
JHS2020
Resolver II
Resolver II

Did you find a solution? 

Depending on the control you use to add the image, there may be some loss in resolution of the image. I think this happens with the Camera control, but not Add Media, via a mobile device, if I recall correctly.

 

When reading from CDS, the image has an embedded property (Full) which is the full resolution of the image (if captured). By default it doesn't send this and you'd need to update your Image controls to delve a layer deeper. ThisItem.AttributeName.Full

It does not work. It is not possible to add full on the image dimension 

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Top Kudoed Authors
Users online (58,147)