cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Image is not showing in email body

Good morning everyone!

I am generating an application that automatically sends you emails with an image taken by the user and that this is printed in the body of the email as the following image:

Cesar_1888_0-1623422027174.png

That ticket in the image above was created from the application on my laptop, but when these were implemented on the company phones, it is sending the emails as follows

Cesar_1888_1-1623422173561.png

Everything runs fine with no issues but only the image prints that way.

To make this possible im using the following codes and variables

- This code saves the image in to a collection

ClearCollect(         
    MyPicture;
    {
        Name: "Evidencia.png";
        ContentBytes: UploadedImage1.Image;
        '@odata.type': ""
    }
);;

 
Then this is how it looks once saved

Cesar_1888_2-1623422555390.png

Then to print the image in the mail i use an HTML text control to save the image

Cesar_1888_3-1623422700133.png


After that i send the email using this code, in the attachments part i send the collection with the image

SubmitForm(Form2_1);;

Office365Outlook.SendEmailV2(
    Concat(
        Gallery2.AllItems;
        Title & ";"
    );
    "Ticket ID: " & Form2_1.LastSubmit.ID & " - " & Form2_1.LastSubmit.Title;
    "
<html>
<head>
<style>
Table {
font-family:arial,sans-serif;
border-Bottom: 1px solid #ddd;
width: 90%;
border-collapse: collapse;
border-spacing: 5px;
}
td {
text-align: center;
padding: 15px;
border-bottom: 1px solid #ddd;
font-size: 12px;
border-collapse: collapse;
}
th {
text-align: center;
padding: 15px;
border-bottom: 1px solid #ddd;
font-size: 12px;
border-collapse: collapse;
}
</style>
</head>
<body>
<h3>A continuacion se tiene un resumen del ticket generado:</h3>
<p> </a></p>
<table>
<tr>
<th>Problema</th>
<th>Descripcion</th>
<th>Area</th>
<th>Proyecto</th>
<th>Prioridad</th>
<th>Estatus</th>
</tr>" & "<tr>
<td>" & Form2_1.LastSubmit.Title & "</td>
<td>" & Form2_1.LastSubmit.Descripciondelproblema & "</td>
<td>" & Form2_1.LastSubmit.Area.Value & "</td>
<td>" & Form2_1.LastSubmit.Proyecto.Value & "</td>
<td>" & Form2_1.LastSubmit.Prioridad.Value & "</td>
<td>" & Form2_1.LastSubmit.Status.Value & "</td>
</tr></table><br>" & ImagenHTML.HtmlText;
    {
        Attachments: MyPicture;
        IsHtml: true
    }
);;

 

Im not sure why works on my laptop but not in the phones, could you please give me an idea of whats going on?

Regards from Mexico!

1 REPLY 1
Anonymous
Not applicable

Another curious fact, if someone answers that email, the image is shown as it should, but this is not correct because it must be displayed correctly from the beginning

Cesar_1888_0-1623423181322.png

 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,400)