cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
agigliotti
Frequent Visitor

Image not refreshing when image field is using a link to an updated image file on a web server

I am having trouble with Powerapps displaying the most current version of a URL linked image file.

 

In a gallery, I am using a SQL Server datasource.  One of the fields in the table is a URL link to an image file on a web server.  The URL is different on each record.  They are pictures of people.  Therefore each record in the table has a URL that links to an image of the person for that record.  This field is the image property of an image control in the gallery.

 

Sometimes, a new picture is taken of that person, or for the current issue I am having, I have resized the image files on the web server so that the resolution is higher.

 

The filename does not change, but the image itself changes.  In other words, a new file is generated with the same name, and overwrites the file.

 

However, on the same day shortly after changing the image file, the users still see the old image on the app.  So far this has been an issue on the iPhone 6.  When a user views this same app on Microsoft Dynamics 365, the user sees the new version of the image file.

 

I have tried using a collection as the data source for the gallery, and on the on visible property of the screen, I use ClearCollect, and use the entire table as both elements of the function.  Not sure if this is correct, but it doesn't fix the problem. 

 

I didn't really expect the ClearCollect to work since this is just loading the link (along with all other fields) into a collection.

 

So far, the only thing that fixes the problem, is having the user uninstall and reinstall Powerapps on their iPhone.

 

My instinct is to find a way to clear the cache of the phone, or maybe it is the cache of Powerapps?

 

Is there anything I can do, and does anyone really know why the image does not seem to refresh on the screen? 

 

 

2 REPLIES 2
v-micsh-msft
Community Support
Community Support

I think the issue here should be related to the Sync between the Mobile and the PowerApps cloud.

 

If the refresh button not working, then please try:

1. Sign out and sign in again,

2. Uninstall and then re-install (which you have tried)

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
hullie
Advocate II
Advocate II

Hi!

 

You could try adding some dummy data to the querystring, so powerapps thinks it is a new url...

So:

http://www/somewebsite.com?id=" & ThisItem.ID & "&refreshid=" & Now()

 

Best regards,

Hullie

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (2,684)