cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Import PowerApps problems

Hello,

 

Our deployment has three (3) environments: Development, Test and Production. PowerApps modules are moved from one environment to the other via the Export / Import functionality. This has been working fine since July 2018. Today, I attempted to Import a PowerApps module from Test to Production. I was able to export the module properly from Test and the file was created in my download folder. However, when I attempt to import the module to Production, PowerApps prompts me to create a new environment. Further, the Import Package link I normally click now says Import Package (preview). I don't want to create a new environment, I simply want to import a package as I always have done prior.

 

Is anyone else experiencing this problem? Your feedback is greatly appreciated.

8 REPLIES 8
Community Support
Community Support

Hi @Anonymous,

 

I just tested to export one app from one environment and import it to another environment. And I can do this successfully. Can you please take a screenshot of the message that PowerApps prompts to create a new environment? 

 

Besides, please make sure that you have followed the steps in below documentation correcly when migrating app between environments:

https://docs.microsoft.com/en-us/powerapps/administrator/environment-and-tenant-migration

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Hello Mona,

 

I appreciate the attention. Please note, there is (currently) only one of our three environments which is not allowing importing. Further, instead of indicating Import Package at the top of the screen, PowerApps now reads: Import Package (preview). When this is selected, a New Environment screen pops up as in this Microsfoft documentation:

https://docs.microsoft.com/en-us/powerapps/administrator/preview-environments

 

Oddly enough, the preview environment is for US-based environments and all three of ours are Canadian-based.

 

 

Hi @Anonymous 

Have you solved your problem?
I have the same problem. Could you please share with me the solution for solving the problem?

Thanks,

BR.
Pytbyt

Anonymous
Not applicable

Hello,

 

The problem fixed itself, somehow.

Hello @Anonymous 

That is magical.. lol

 

So, what should i do? Should i wait? 
Or there specific things should i done beside waiting?

Thanks,

pytbyt

Anonymous
Not applicable

I think that is what I did. Just waited. I do not think the Sys admin did anything to cause it or fix it.

@Anonymous 

**bleep**.... 

So, i guess this is a bug? or a glitch eh?

Huft...

 

Thank for your replies mate, i'll be waiting and try to sign off and sign in again into the powerapps.

 

Cheers,

pytbyt

Anonymous
Not applicable

My pleasure. Wish I could be of more help.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (8,999)