cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AterCZ
Regular Visitor

Importing solution

Hi,

I've created a solution which contains approximately the following:

  • 2 canvas app (added existing)
  • 5 flows (added existing mostly)
  • 2 connection references
  • 4 environment variables for the Sharepoint lists

I tried exporting and importing the solution into another tenant, both managed and unmanaged and both into the default and non-default environments. Problems I face in all scenarios:

 

  • Flows do not pick up the connection references 'invalid connection' and import as turned off (see screenshots). I need to individually open all flows and click on the connections in all steps needing them (in my case Sharepoint and Mail)

1.JPG2.JPG3.JPG

 

  • The behavior of canvas apps with the data sources is weird and changing. I added the Sharepoint data sources to the canvas apps
    • 1) add data source
    • 2) advanced
    • 3) used the environment variables.
  • When imported to the new tenant, firstly a lot of errors appeared when opening the app and I needed to go to the app, delete the data sources and add them again. Now with one app it's working fine, with the other it doesn't pick up the new values I put in the environment variables and seems to keep pointing at the old tenant's Sharepoint.

 

Could I ask for pointers what to try and change?

1 ACCEPTED SOLUTION

Accepted Solutions
Rivius
Resolver III
Resolver III

That's a tough one to answer because I've noticed a difference in behavior between "old" flows and "new" flows (based on when I created them).  Old ones misbehave but new ones seem to transport in solutions without problem and even bring up a menu of connections to verify that apply to the entire flow!

View solution in original post

3 REPLIES 3
Rivius
Resolver III
Resolver III

The connections are 'missing' because they aren't in the new tenant so upon first setting up the flow you'll need to setup that connection (totally normal behavior).

Flows import as disabled (this is known, and totally normal behavior).

 

Unfortunately I've done a LOT of importing/exporting and what you're experiencing is completely normal and I've even talked to MS help about it who confirmed the behavior.

 

One thing I would recommend is to put everything BUT the canvas app in your solution and migrate that separately. 

 

If you plan on doing this often, document the steps you take for yourself and the process will become 'normal'.

AterCZ
Regular Visitor

Thank you for your answer. My question is then if it's even worth it to use Solutions for Flows. When I export and import them one by one, the connections in Flows work fine. With Solutions going through the whole flow and setting the connections is error-prone...

Rivius
Resolver III
Resolver III

That's a tough one to answer because I've noticed a difference in behavior between "old" flows and "new" flows (based on when I created them).  Old ones misbehave but new ones seem to transport in solutions without problem and even bring up a menu of connections to verify that apply to the entire flow!

View solution in original post

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (1,447)