cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate I
Advocate I

Improved app rendering issue (no refresh of one DataCardValue when opening DataCard)

After turning "improved app rendering" on, there was one (lookup) field in my displayform that kept the value from the previously displayed sharepoint item when opening the form. All other 24 field values are picked up correctly from the sharepoint item.  Some of them are also lookup fields, but the field I'm having the issue with, is the only one of type 'person or group'. The user has to refresh each time after opening a form, to get the correct value in de (commercial contact name) lookup field.

 

So I had to turn "improved app rendering" off for my app  and then it works correctly. 😞

 

Anyone else having this problem or a solution, so I can turn "improved app rendering" on?

 

Thanks,

Martine.

7 REPLIES 7
Highlighted
Community Support
Community Support

Hi @Martine,

 

First of all, I'd like to explain that the "Improved App Rendering" functionality is used to render an app in more efficient way. The "Render in Classic mode" functionality is used to render an app in a classic app rendering way.

 

Some new experimental features released within the canvas app are based on the "Improved App Rendering" functionality, In other words, if you want to use the new experimental features (e.g. Try the enhanced Group control) within the Canvas app, you must turn on/enable the "Improved App Rendering" option.

 

Then, would your please tell what exactly is the column type of the one column that you are having trouble with? According to your description, 2 column types are mentioned which are Lookup and Person/Group. I'm quite confused. Please explain what exactly is the column type of this field you chose in SharePoint list while first time creating it. 

 

I assume that it is a lookup column and with the "improved app rendering" on, I just tested to create an auto-generated app using SharePoint list connection. In both Gallery and Form controls, Lookup field shows the data correctly and I can pick the data from the dropdown control inside edit form.

Capture.JPGCapture.JPG

So please create a new app to test if your app the created before. 

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Mona,

 

Thanks for the information.

Sorry for my mistake.  It is not a lookup field.  It's a Person/Group field.

 

I did the test with a new list having 2 fields.  Title (text field) & Person (Person/Group field).

I do still have the problem when improved app rendering is on.  The issue only occurs after publish (so not when testing during app creation).

gebruikersnaam_issue.jpg

 

 

So

(1) after selecting item 1,

(2) going back to the list

(3) and then selecting item 2. 

The person name of item 1 is still displayed.

 

Regards,

Martine.

 

 

Highlighted

I am having the exact same problem with my details screen, please help!

Highlighted

I found this solution in another post that fixed the issue for me, hope it helps you.  I turned both options off.

 

 
Profile picture of v-xida-msft
Community Support Team Rank
Community Support Team
Re: BUG: View Form
 

Hi @PowerAnalytics,

Do you mean that the issue only appears in your Mobile device?

I have made a test on my side, and don't have the issue that you mentioned. I think this issue is not related to the Choice field in your SP list.

Please make sure the Item property of the Display form control is set to following:

BrowseGallery.Selected

Please also take a try to turn off/disable the "Improved app rendering (final validation)" option and "Delayed load" option within Advanced settings of App settings of your app, then re-publish your app, then try your PowerApps Mobile App again, check if the issue is solved.

In addition, please also check if the version of your PowerApps Mobile App in your Mobile device is the latest version, if not, please upgrade it into the latest version, then check if the issue still exists.

If the issue still exists, please consider re-create your app or re-install PowerApps Mobile App in your Mobile device, then check if the issue is solved.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted

I'm sorry, but turn off/disable the "Improved app rendering (final validation)" option, is not the solution because it is the issue!

I want "improved app rendering" to be enabled and then the refresh issue occurs (see Subject).

 

 

Highlighted

I agree, it’s a bug. Until the bug is fixed this appears to be the only option. 

Highlighted

And today I have another issue where my app only works when turning "improved app rendering" off. Woman Sad

I hope "classic app rendering" will not be removed before all issues are solved!!

 

I will create a new discussion : Improved app rendering issue 2 (VisibleIndex problem)

 

 

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (9,701)