cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

Improved app rendering issues continue

So I tried converting a "classic" mode app to the new "improved app rendering" mode and it stopped working in preview mode. 

 

Specific details:

 

  • It is a single screen app.
  • When I click the navigation gallery it should refresh the data, but it doesn't now

When I publish the app, it appears to work, but it's potentially disasterous if I have to publish an untested app.

My app is published in PowerApps version is 3.18084.12

 

-Jamie

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Microsoft
Microsoft

Hello @Anonymous,

Aside for providing the session id, could you please clarify what do you mean by "click the navigation gallery"? Please also note that the interaction mode is "off" by default in "improved rendering" mode so you may need to click on "Preview" button before testing your application.

View solution in original post

8 REPLIES 8
Highlighted
Power Apps
Power Apps

Can you get the session ID ( https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/get-sessionid ) and the team can look into this?

Highlighted
Anonymous
Not applicable

The session id is 3a12ff19-1d6b-439e-9dd5-d8ec3bcb9554

Highlighted
Anonymous
Not applicable

adding @EvanChakiMSFT in to assist

Highlighted
Anonymous
Not applicable

I'm not really sure how to report all the issues I see with the "improved app rendering" because they seemingly random and difficult to replicate.  It's very frustrating.  Often I find the only remedy is (besides going "classic"), is to close the app and reopen it.  I don't know why this works, but it seems to solve a lot of random errors and unexplainable behavior.

 

 

Highlighted

We are looking into your session id.  Thank you for posting it.

Highlighted
Anonymous
Not applicable

Happy to help.  Every issue I've encountered seems to get resolved by closing and reopening the app.  The only exception was I tried to use the new ehanced Group on several controls and they all got deleted.  Closing and re-opening the app did not work. I had to restore a previous version of my app to get them back.  

Highlighted
Microsoft
Microsoft

Hello @Anonymous,

Aside for providing the session id, could you please clarify what do you mean by "click the navigation gallery"? Please also note that the interaction mode is "off" by default in "improved rendering" mode so you may need to click on "Preview" button before testing your application.

View solution in original post

Highlighted
Anonymous
Not applicable

I haven't had as many issues in the past 2 weeks so I'm closing this thread.  If I have anything concrete, I'll create a new thread. 

 

BTW - "navigation gallery" simply refered to a gallery control that I was using to control the filtering of other controls in the single screen app.  For example, if the user clicks ACME, the four other gallerys are filtered to only show records with the ACME brand.   Unlikely to be relevant to the issue, but you asked. 

 

Thanks,

Jamie

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (9,309)