cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jlister
Advocate III
Advocate III

Improved app rendering issues

I received banner message asking me to try using the improved app rendering. When activating this feature the combo boxes don't align correctly and do not allow me to select an option using the web player. The other issue I am experiencing while using the improved app rendering feature is the options inside the  list box control are not displaying. Switching back to classic rendering fixes both issues.

Unable to select an employeeUnable to select an employee

100 REPLIES 100
ericonline
Community Champion
Community Champion

Hello,

I also confirmed that Combobox selections now work in the IDE preview.

I also confirm that comboboxes issue is now solved. 

But still improved rendering does not work - all items are on top of each other and hidden items are visible. 

@SilverK This sounds like a layout exception.  What are the chances you have a form with groups or other non-datacard controls as immediate children?

karacsondi
Frequent Visitor

We are having an issue with Navigate (with 'none' animation effect) between screens containing galleries - as you can see on the gif below, it shows in a kind of overlapping way on the galleries before the new screen would be fully loaded. It happens only over galleries (where item source is a delegatedly filtered SPO list), and it works perfectly with 'classic' rendering.

 

Any tips on how it can be fixed with improved rendering is ON? We are fine with classic rendering also as soon as the 'improved' one is not forced, but I'm afraid the clock is ticking...

@karacsondi Can you set Gallery.Transition to None and check if it still happens? I want to make sure it is a bug we are aware of.

@tahoon : Changed it from .push to .none at both galleries but it still happens.

I don't observe this problem with my apps.

  • Have you tried other browsers?
  • Is the gallery at the top-level or inside another control like another gallery, a scrollable container, or form?
  • Does it happen with all galleries? What about other apps?

Same behavior in Chrome and FF, gallery is at top level of a non-scrollable screen. Problem got solved by re-creating the gallery in a new screen within the same app with the same setup, where it works properly. Weird enough but I let it go.

hjaf
Advocate V
Advocate V

I have issues with the app restarting (or crashing) all the time. It may be more likely to happen when scrolling through large galleries and lists with 100-300 items, but sometimes it seems to happen randomly as well. There is no error so I can only guess the reason beyond this point. I found someone mentioning the improved rendeing is the cause.  I have done some testing and indeed it seems to be much more stable and responsive now that I have disabled the improved rendering.  We are running iOS 12.2 and PowerApps 3.19053.21

Will developers enforce the new rendering even when there are issues like this present? Anyone else experienced similar issues?

I have tried improving some of the forms and screens by pure speculation on what could be memory/cpu intensive, but it is a waste of time unless I have some hint as to what the cause is. There should be some error messages available to the app designers.  Perhaps there already is, if so, where? 🙂 

@hjaf This is a reported issue that we are actively investigating--particularly related to iPhone devices.  We will update this thread as we know more.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (2,855)