cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Infinite loop when playing PowerApp from tile

In the last few days I have had a problem playing PowerApps from the tile layout on the https://web.powerapps.com url. It is affecting new apps as well as ones that have not changed and have previously been working.

 

Every time I click a tile to play an app I get an 'Infinie loop detected' message. However, if a play the apps from another screen, e.g. the Share screen, then they work.

 

Has anybody else seen this problem please?

1 ACCEPTED SOLUTION

Accepted Solutions

Thanks @AndyPennell. 🙂

@Anonymous, please see the thread for reference.

WebAuthoring abnormal termination

And follow the steps quoted below

Quoted:

"

Response from David Nissimoff [MSFT] ** PowerApps Staff

"

As Andy suggested, this is likely due to security settings configured in Internet Explorer (they apply to Edge as well). Please verify the following:

  • In IE, click the gear icon on the top right and go to Internet Options
  • Under the Privacy tab, click "Advanced":
    • Make sure "First-party Cookies" are set to Accept
    • Make sure "Third-party Cookies" are set to Accept (we use this for authentication with Azure Active Directory. From the perspective of PowerApps, Azure AD is a third-party)
    • If enabling third-party cookies is not an option for you, please at least enable "Always allow session cookies"
  • If the above still doesn't solve your problem, go to the "Security" tab and ensure the sites "https://login.microsoftonline.com"and "https://create.powerapps.com" are in the same zone.
    • Select "Restricted sites", then click the "Sites" button and ensure none of the websites above are listed.
    • Select "Trusted sites", then click the "Sites" button. Make sure that you either have none or that you have both on the list. If you only have one of them, this can cause the problem you experienced.

NOTE: Some organizations may prevent you from changing these settings manually. If you don't see the options I described above, you might have to contact your IT department for assistance.

 

Hopefully this will get you going. If it doesn't, please let me know and we can try additional troubleshooting steps.

 

"

Regards,

Michael

 

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

9 REPLIES 9
v-micsh-msft
Community Support
Community Support

Hi @Anonymous,

 

Do you mean when opening app from the PowerApps home page (Recent Apps ?), it will show the error messages mentioend?

32.PNG

Would you please share a screenshot of the error messages?

 

I have no errors opening the App from the home page, the app would be loaded successfully in a new page.

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Yes thats right. It used to be fine. If I click the Start New Session button a few times it then displays an infinite loop error.

 

powerappsCapture.PNG

Hi @Anonymous,

 

Thanks for the screenshots.

The Session ID mentioned here should be: a9a2b24b-d13a-6edd-9eba-a03c4f2e0395, right?

Hope it would be convenient for @AndyPennell  (PowerApps staff ) to take a further investigation regaridng the Session ID.

Besides, would it be available for you to copy the error message and paste it here?

Regards,

Michael

 

 

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Thanks.

 

The error message is:

 

"WebAuthoring abnormal termination.
Client date/time: 2017-04-12T12:56:57.764Z
Version: 2.0.610
Session ID: 1979ad83-6770-bff5-e847-e8729d10dbf8
description: {"error":{"detail":{"exception":{}},"colno":0,"filename":"https://paaweucdn.azureedge.net/v2.0.610.0/studio/openSource/modified/winjs/js/base.js?v=39de24830fe... error","initErrorEvent":"[function]","bubbles":false,"cancelBubble":false,"cancelable":false,"currentTarget":"[window]","defaultPrevented":true,"eventPhase":2,"isTrusted":true,"srcElement":"[window]","target":"[window]","timeStamp":1492001817749,"type":"error","initEvent":"[function]","preventDefault":"[function]","stopImmediatePropagation":"[function]","stopPropagation":"[function]","AT_TARGET":2,"BUBBLING_PHASE":3,"CAPTURING_PHASE":1},"errorLine":0,"errorCharacter":0,"errorUrl":"https://paaweucdn.azureedge.net/v2.0.610.0/studio/openSource/modified/winjs/js/base.js?v=39de24830fe... error","setPromise":"[function]","exception":{}}
stack: null
errorNumber: 0
errorMessage: Script error"

 

 

Then if I click the start new session 3 times I get:

 

 

powerappsCapture.PNG

 

@v-micsh-msft I can confirm that both the listed session ids are the same Authentication issue in the thread yesterday.

Thanks @AndyPennell. 🙂

@Anonymous, please see the thread for reference.

WebAuthoring abnormal termination

And follow the steps quoted below

Quoted:

"

Response from David Nissimoff [MSFT] ** PowerApps Staff

"

As Andy suggested, this is likely due to security settings configured in Internet Explorer (they apply to Edge as well). Please verify the following:

  • In IE, click the gear icon on the top right and go to Internet Options
  • Under the Privacy tab, click "Advanced":
    • Make sure "First-party Cookies" are set to Accept
    • Make sure "Third-party Cookies" are set to Accept (we use this for authentication with Azure Active Directory. From the perspective of PowerApps, Azure AD is a third-party)
    • If enabling third-party cookies is not an option for you, please at least enable "Always allow session cookies"
  • If the above still doesn't solve your problem, go to the "Security" tab and ensure the sites "https://login.microsoftonline.com"and "https://create.powerapps.com" are in the same zone.
    • Select "Restricted sites", then click the "Sites" button and ensure none of the websites above are listed.
    • Select "Trusted sites", then click the "Sites" button. Make sure that you either have none or that you have both on the list. If you only have one of them, this can cause the problem you experienced.

NOTE: Some organizations may prevent you from changing these settings manually. If you don't see the options I described above, you might have to contact your IT department for assistance.

 

Hopefully this will get you going. If it doesn't, please let me know and we can try additional troubleshooting steps.

 

"

Regards,

Michael

 

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Anonymous
Not applicable

Didn't have create.powerapps.com in  the same zone as microsoftonline.com.

 

This has fixed it. Thanks.

Hi, I have the same problem.

Powerapps open well, but when I try to edit an app the app don't open and show this message:

BeforeAadLoginTimestamp: 1515611429683
NumAttempts: 
Error: InfiniteLoop
ErrorDescription: Infinite loop detected.

[INFO] [2018-01-10T19:10:29.670Z] Starting...
[INFO] [2018-01-10T19:10:29.682Z] User is not signed in
[INFO] [2018-01-10T19:10:29.683Z] Found query , hash action=edit&source=portal&app-id=%2fproviders%2fMicrosoft.PowerApps%2fapps%2f39eea036-478b-4077-b948-c6c430121723
[INFO] [2018-01-10T19:10:29.683Z] Navigating to AAD
[INFO] [2018-01-10T19:10:29.688Z] ADAL log: Wed, 10 Jan 2018 19:10:29 GMT:1.0.13-INFO: Navigate url:https://login.microsoftonline.com/common/oauth2/authorize?response_type=id_token+token&client_id=0cb2a3b9-c0b0-4f92-95e2-8955085f78c2&resource=https%3A%2F%2Fmanagement.core.windows.net%2F&redirect_uri=https%3A%2F%2Fcreate.powerapps.com%2Fstudio%2F&state=2fed3c3c-1581-4f8c-a74b-0b53335eb14d&client-request-id=b744e642-c384-4ee2-abc6-89bb42c8f35d&x-client-SKU=Js&x-client-Ver=1.0.13
[INFO] [2018-01-10T19:10:29.688Z] Navigating to: https://login.microsoftonline.com/common/oauth2/authorize?response_type=id_token+token&client_id=0cb2a3b9-c0b0-4f92-95e2-8955085f78c2&resource=https%3A%2F%2Fmanagement.core.windows.net%2F&redirect_uri=https%3A%2F%2Fcreate.powerapps.com%2Fstudio%2F&state=2fed3c3c-1581-4f8c-a74b-0b53335eb14d&client-request-id=b744e642-c384-4ee2-abc6-89bb42c8f35d&x-client-SKU=Js&x-client-Ver=1.0.13&nonce=04e408da-461b-4bc9-9909-2b16f1461a16
[INFO] [2018-01-10T19:10:30.259Z] Starting...
[WARN] [2018-01-10T19:10:30.262Z] Going to error page: InfiniteLoop, Infinite loop detected.
[WARN] [2018-01-10T19:10:30.263Z] Login failed: InfiniteLoop: Infinite loop detected.
Anonymous
Not applicable

I am getting this too.  It only started today.  Other than that it has been working fine until the end of March 2018!

 

What's changed?

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Top Kudoed Authors
Users online (937)