cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
utsav_ghosh1
Advocate II
Advocate II

Integrate PowerBI report in Powerapps

Hi all,

 

I want to integrate powerBI report in powerapp. i have used the PowerBI tile in the powerapps and connected it to the site, workspace and report.

 

The powerBI doesnt open and gives an error "app.powerbi.com refused to connect". after checking the network trace i saw additional error there. 

 

"Refused to display 'https://app.powerbi.com/sharedwithme/reports/b92a74bb-dd9b-4f6e-a230-6ad88645cf78/ReportSection745ba...' in a frame because it set 'X-Frame-Options' to 'deny'."

1 ACCEPTED SOLUTION

Accepted Solutions
v-xida-msft
Community Support
Community Support

HI @utsav_ghosh1 ,

Do you run your app using Mobile device? Does this issue also occur within web browser?

 

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned. The screenshot as below:

5.jpg

 

According to the first screenshot that you provided, I found that you want to pass a parameter to the TileUrl property of Power BI tile control, is it true?

Based on the Filter formula you typed, I think there is something wrong with it. You have missed a '$' symbol before the filter key word. Please consider modify the TileUrl property of the Power BI tile control as below:

"https://app.powerbi.com/embed?dashboardId=<DashboardID>&tileId=<TileID>&config=<SomeHash>&$filter=Locations/Location eq 'Sappemeer Kantoor'"

Note: Please do not miss the '$' symbol before the filter key word.

Please check the following article for more details:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/controls/control-power-bi-tile#pass-a-p...

 

Please also check if you have proper Power BI license for your account. Also please make sure the Power BI license for your current account is not expired.

 

When you run your app in Mobile device first time, it would display a prompt to ask for your Power BI access permission, please click the "Allow" option to allow your canvas app to access your Power BI report.

 

Also please consider create a new app, try your Power BI tile control again, check if the issue is fixed.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
SeanHenderson
Impactful Individual
Impactful Individual

Is the issue only occurring in browser, or when running app on mobile as well. Are you using Chrome? I know I've had this issue with Chrome before.

v-xida-msft
Community Support
Community Support

HI @utsav_ghosh1 ,

Do you run your app using Mobile device? Does this issue also occur within web browser?

 

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned. The screenshot as below:

5.jpg

 

According to the first screenshot that you provided, I found that you want to pass a parameter to the TileUrl property of Power BI tile control, is it true?

Based on the Filter formula you typed, I think there is something wrong with it. You have missed a '$' symbol before the filter key word. Please consider modify the TileUrl property of the Power BI tile control as below:

"https://app.powerbi.com/embed?dashboardId=<DashboardID>&tileId=<TileID>&config=<SomeHash>&$filter=Locations/Location eq 'Sappemeer Kantoor'"

Note: Please do not miss the '$' symbol before the filter key word.

Please check the following article for more details:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/controls/control-power-bi-tile#pass-a-p...

 

Please also check if you have proper Power BI license for your account. Also please make sure the Power BI license for your current account is not expired.

 

When you run your app in Mobile device first time, it would display a prompt to ask for your Power BI access permission, please click the "Allow" option to allow your canvas app to access your Power BI report.

 

Also please consider create a new app, try your Power BI tile control again, check if the issue is fixed.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Hi @v-xida-msft

 

I have a valid license for PowerBI, since i am able to publish the report my self. I have tried adding the $filter but still no luck

 

Also on the mobile device, the screen on the Powerapp which has the powerbi tile is blank. it doesnt show any error. And i have also tried running the app on desktop IE, getting error "this content cannot be displayed in a frame"

 Desktop Internet ExplorerDesktop Internet ExplorerIpad iOS 13.2.2Ipad iOS 13.2.2

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Top Kudoed Authors
Users online (21,200)