cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
NPBA_AT
Level 8

Intermittently get 'An unknown error occurred' on Sharepoint List Lookup...connection then lost

We are getting an intermittent error "An unknown error occurred" after entering a barcode number which does a lookup to a Sharepoint Online List.  The lookup fails (producing a message generated by the app that "There is no tool with this barcode") and the connection to the Sharepoint List is gone and cannot be recovered. App has to be restarted and once it has been the Tool checkout transaction can be done successfully.

I have checked that the PC still has internet connectivity (it does), and though the symptoms appear to be the same if I disconnect the network cable, that does produce a more meaningful message about failing to contact the server. I'm wondering if there is some timeout somewhere that we are hitting and the connection just closes?  This happens multiple times a day.

I have another PowerApp that I developed recently that is using Sharepoint Lists from the same site and is also in use all day by multiple users and that app is not having this issue.  

Does anyone have any ideas what could be causing this?

11 REPLIES 11
NPBA_AT
Level 8

Re: Intermittently get 'An unknown error occurred' on Sharepoint List Lookup...connection then lost

@anees @v-micsh-msft  Microsoft staff - can you please provide some assistance on how I can diagnose an intermittent error that I cannot reliably reproduce when all I get is "An Unknown Error Occurred"? How can I get support on this?  This is the session ID of a session where a submit failed at about 4:08pm New Zealand Time today: 

Capture4.PNG

This app is failing intermittently anywhere in the app where a read or write to the Sharepoint list occurs. The connection to the Sharepoint List just appears to be dropped, but the PC's connection to the internet is still working. This is a LIVE application that is failing and not providing sufficient information to understand why.  Please help.

Community Support Team
Community Support Team

Re: Intermittently get 'An unknown error occurred' on Sharepoint List Lookup...connection then lost

Hi @NPBA_AT,

 

Have you tried to delete this connection inside the app and then readd it again? If this doesn't work, please check on the PowerApps connection list site, make sure that this connection's status is Connected. If not, fix the connection there.

Capture.JPG

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
NPBA_AT
Level 8

Re: Intermittently get 'An unknown error occurred' on Sharepoint List Lookup...connection then lost

Thanks for getting back to me Mona. Yes, the connection has been re-added in the app and app republished but this intermittent issue keeps occurring. The app starts up and works for hours and then the connection appears to just drop off and the app starts to fail on a data lookup or write but with unhelpful error msg. The app has to be shut down and restarted to get the connection back. Refreshing the data connection within the app doesn’t help.
Does “the PowerApps Connection list site” show the status of connections for different sessions of the app that are running? As the app is being used by someone at a separate location to me, am I able to see what is happening to their connection if they let me know when the app fails, or does someone need to look at this on their PC? How would I fix the connection there? Can you point me to support documentation about this? Thanks, Anne
NPBA_AT
Level 8

Re: Intermittently get 'An unknown error occurred' on Sharepoint List Lookup...connection then lost

Hi Mona @v-monli-msft

We are still having this issue.  I see another thread that appears to have the same issue:

https://powerusers.microsoft.com/t5/General-Discussion/Data-connection-timeouts-without-error-or-war...

 

Is this a known issue?  Is Microsoft looking at this issue? 

Power Apps Staff anees
Power Apps Staff

Re: Intermittently get 'An unknown error occurred' on Sharepoint List Lookup...connection then lost

@NPBA_AT checking to see if anyone knows why this may be happening. Will get back.

- Anees

NPBA_AT
Level 8

Re: Intermittently get 'An unknown error occurred' on Sharepoint List Lookup...connection then lost

Hi @anees,

Any progress on this? Is there any information that you need from us to help investigate this?

Or do I need to log a support ticket about this?

Thanks,

Anne

NPBA_AT
Level 8

Re: Intermittently get 'An unknown error occurred' on Sharepoint List Lookup...connection then lost

Hi @anees,

Just thought I'd add that we seem to get this error message if trying to write to SharePoint when the connection has "dropped off": "There was a problem saving your changes. The data source may be invalid". 

Why is our data source suddenly invalid when it has been fine for hours, and the internet connection is still up? We restart the app and then it's fine again. 

 

Would appreciate some assistance with this issue, as having an ongoing intermittent fault does not make the PowerApps environment look stable. 

 

Regards,

Anne

Power Apps Staff anees
Power Apps Staff

Re: Intermittently get 'An unknown error occurred' on Sharepoint List Lookup...connection then lost

@NPBA_AT, I mentioned this to @AlanC and looks like he was following up on the linked thread.

 

@AlanC can you please reach out to @NPBA_AT as well?

 

Thanks

Anees

Power Apps Staff AlanC
Power Apps Staff

Re: Intermittently get 'An unknown error occurred' on Sharepoint List Lookup...connection then lost

Hi @NPBA_AT, I took another look to the telemetry, I see a lot of errors calling to SharePoint with a 429 response:

 

{
  "statusCode": 429,
  "message": "Rate limit is exceeded. Try again in 5 seconds."
}

 

What this error means is that this particular connection is making a lot of calls in a very short amount of time, it looks like your app has a lot of burst in which it makes between ~100 and 200 calls per second, this is very unusual.

 

I can't tell from telemetry what your app is doing to be causing so many calls. One possibility is that you may be making a call per item after a refresh, for example a scenario that would cause this behavior would be to have a ForAll call after a Refresh that uses the value from one of the item's properties to make a call to another data source. My suggestion would be to modify your app to avoid making so many calls at the same time, unfortunatelly without the specifics of your app I can't give any specific suggestions.

 

Thanks,

Alan

Helpful resources

Announcements
Better Together’ Contest Finalists Announced!

'Better Together’ Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Join THE global Microsoft Power Platform event series

Attend for two days of expert-led learning and innovation on topics like AI and Analytics, powered by Dynamic Communities

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

thirdimage

Microsoft Business Applications Virtual Launch

Join us for the Microsoft Business Applications Virtual Launch Event on Thursday, April 2, 2020, at 8:00 AM PST.

thirdimage

Community Summit North America

Innovate, Collaborate, Grow - The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Top Kudoed Authors
Users online (9,741)