cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Invalid app site map

Hi,

I'm trying to see my model-driven app after hitting "Publish" but it keeps returning me the message that my site map is invalid (see photo below, in Portuguese).

Even when the "Validate" returns no error or dependence issue.

How do I fix it?

 

Is this something related with my trial period (in the photo as "Tipo: EmailTrial") ?

 

error.PNG

 

 

 

2 ACCEPTED SOLUTIONS

Accepted Solutions

Go to the model driven app designer. Open the site map designer. Make one change to it such as moving one of the subareas. Save and publish the sitemap 

https://docs.microsoft.com/en-us/powerapps/maker/model-driven-apps/create-site-map-app

View solution in original post

Anonymous
Not applicable

Just to update the feed with a solution, my app is working just fine.

I didn't do anything, it just works now.

I figure we should give it some time to think.

View solution in original post

10 REPLIES 10

Go to the model driven app designer. Open the site map designer. Make one change to it such as moving one of the subareas. Save and publish the sitemap 

https://docs.microsoft.com/en-us/powerapps/maker/model-driven-apps/create-site-map-app

View solution in original post

Anonymous
Not applicable

I've tried this before, but it didn't worked out.

In that case, remove all subareas and rebuild it. Are you just displaying entities or also custom web resources?

Anonymous
Not applicable

I'm using just one subarea, displaying one entity.

The only change I made was create a new entity form.

 

I've just created a new model driven app from scratch, using the same entity, and it keeps returning me the same thing.

 

The problem may be the entity or the license.

Also, how much time is left on your trial? Of it is expired that could cause this issue

 

Export a solution with your app in it to a new trial

Anonymous
Not applicable

Going to try it exporting it.

I have 15 days on my trial yet

You should be ok then. Please post a screenshot of your subarea properties

Anonymous
Not applicable

Just to update the feed with a solution, my app is working just fine.

I didn't do anything, it just works now.

I figure we should give it some time to think.

View solution in original post

could be a quirk, also sometimes things get cached.

 

I have seen changes made and published to sitemaps not show up unless something else in the app changes. These things work themselves out in 24-48 hours

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

R2 (Green) 768 x 460px.png

Microsoft Dynamics 365 & Power Platform User Professionals

DynamicsCon is a FREE, 4 half-day virtual learning experience for 11,000+ Microsoft Business Application users and professionals.

Users online (1,631)