cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Black_Magic100
Helper I
Helper I

Invalid argument type (GUID). Expecting a table value instead.

I seriously can not figure out how to fix this error.  My google search is filled with purple links because I have checked every single article imaginable and yet I still can not fix this problem.  I have absolutely no idea why this is not working.  

1 ACCEPTED SOLUTION

Accepted Solutions
aorphan
Resolver I
Resolver I

@Anonymous has the solution, but he didn't explain it. Let me give you the whole solution and explanation on how to fix this. I was also experiencing this problem and it was annoying the heck out of me and I couldn't find a solution so I had to solve it myself.

screenshot1.png

This error occurs because of the way Powerapps auto-generates code for Data Cards’ MaxLength property. Notice the generated property value here:
screenshot2.png

Well, evidently there is an issue with the reference to my entity name ‘FCO Technicians’. Specifically, the reference is ambiguous because the Entity name conflicts with the system-generated Unique Identifier (aka primary key):
screenshot3.png
The fix is to use the disambiguation operator like this (requires unlocking the Data Card):
screenshot4.png

More on the disambiguation operator here: https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/functions/operators#disambiguation-operator

Be wary of this problem and be careful naming your entities going forward. Ultimately, this is a bug with Powerapps auto-generating bad code and should be fixed by Microsoft at some point.

If this solved your problem, kindly mark it as the solution and vote it up! 

View solution in original post

10 REPLIES 10
timl
Super User III
Super User III

Hi @Black_Magic100 

Where are you seeing this error? What formula are you using? Can you post a screenshot?

I'm not using any formula. Just pulling from a very simple entity I created and every single **bleep** time I get this error. It's just a text/string attribute
Thierry11
New Member

I'm having a similar issue.
guidinvalid.PNG

When I hover over the X, the error tells me: Invalid argument type (GUID). Expecting a table varibale instead.
When I hover over the DataSourceInfo, the error tells me: the Function DataSourceInfo has some invalid arguments. I've followed the DataSourceInfo documentation step by step, I'm not sure what is going one. 

Thank you

Anonymous
Not applicable

Hi Thierry,

Just replace 'Feedback' with '[@Feedback]'. That should solve the problem.

I fixed this issue 2 months back by simply changing something in the settings, but I accidentally had to get rid of my app and republish it and it messed up again.  This fix does not work though.  It gives another error "The function 'DataSourceInfo' has some invalid arguments.

 

 

aorphan
Resolver I
Resolver I

@Anonymous has the solution, but he didn't explain it. Let me give you the whole solution and explanation on how to fix this. I was also experiencing this problem and it was annoying the heck out of me and I couldn't find a solution so I had to solve it myself.

screenshot1.png

This error occurs because of the way Powerapps auto-generates code for Data Cards’ MaxLength property. Notice the generated property value here:
screenshot2.png

Well, evidently there is an issue with the reference to my entity name ‘FCO Technicians’. Specifically, the reference is ambiguous because the Entity name conflicts with the system-generated Unique Identifier (aka primary key):
screenshot3.png
The fix is to use the disambiguation operator like this (requires unlocking the Data Card):
screenshot4.png

More on the disambiguation operator here: https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/functions/operators#disambiguation-operator

Be wary of this problem and be careful naming your entities going forward. Ultimately, this is a bug with Powerapps auto-generating bad code and should be fixed by Microsoft at some point.

If this solved your problem, kindly mark it as the solution and vote it up! 

View solution in original post

ahhh okay so in my case I did not need the single quotations, which was what was causing the second error that was populating.  Thanks!!

Okay I actually spoke slightly to soon.... how do you fix the issue for dropdowns in edit forms?

 

The exact same erorr is now populating in the "AllowedValues" property as there is no MaxLength property.

 

Here is my code inside:

 

DataSourceInfo([@LineItems], DataSourceInfo.AllowedValues, "cre88_category")

 

"The code above fixed the GUID table error, but then I get the "The function 'datasourceinfo' has some invalid arguments"

Hello,

 

I am facing same error for MaxLength .

I have changed it to - DataSourceInfo([@Table1],MaxLength,"Id") , still I can see same error.

Is there any other way to fix it?

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

PowerPlatform 768x460.png

Microsoft Learn

Check out our new Discover Your Career Path blog post series and get all the details.

Users online (3,128)