cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
OvyOne
Helper I
Helper I

Is it possible to use On-premises Data Gateway with SharePoint Foundation 2013?

Hello Community,

 

Did anyone try to use On-premises data gateway with SharePoint Foundation 2013? 🙂 yes I know... who is using SharePoint Foundation anymore? I'm using it for demo purposes.

Can you share your experience if this is possible?

 

Kind regards,

Ovi.

1 ACCEPTED SOLUTION

Accepted Solutions
v-yamao-msft
Community Support
Community Support

Hi Ovi,

 

From this document, we know that PowerApps is supporting for SharePoint on-premises lists, we can use a single gateway to create connections to any number of on-premises data sources. Please check this link for a reference:
https://powerapps.microsoft.com/en-us/blog/support-for-sharepoint-on-premises/

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

6 REPLIES 6
v-yamao-msft
Community Support
Community Support

Hi Ovi,

 

From this document, we know that PowerApps is supporting for SharePoint on-premises lists, we can use a single gateway to create connections to any number of on-premises data sources. Please check this link for a reference:
https://powerapps.microsoft.com/en-us/blog/support-for-sharepoint-on-premises/

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Hello Mabel,

 

Thank you for your reply. I checked the reference provided (https://powerapps.microsoft.com/en-us/blog/support-for-sharepoint-on-premises/) and I was able to install/configure the On-Premises Data Gateway. Once I created the gateway I checked its status at web.powerapps.com under Gateways and it shows Live.

 

 

Hello Mabel,

 

Thank you for your reply. I checked the reference provided (https://powerapps.microsoft.com/en-us/blog/support-for-sharepoint-on-premises/) and I was able to install/configure the On-Premises Data Gateway. Once I created the gateway I checked its status at web.powerapps.com under Gateways and it shows Live.

 

Gateway Live.jpg

 

 

 

 

 

 

 

 

 

 

 

 

Next I created a SharePoint on-premises connection using the gateway created in the previous step. This was created successfully as well.

 

 

 

SharePoint on-premises connection.jpgHello Mabel,

 

Thank you for your reply. I checked the reference provided (https://powerapps.microsoft.com/en-us/blog/support-for-sharepoint-on-premises/) and I was able to install/configure the On-Premises Data Gateway. Once I created the gateway I checked its status at web.powerapps.com under Gateways and it shows Live.

 

Gateway Live.jpg

 

 

 

 

 

 

 

 

 

 

 

 

Next I created a SharePoint on-premises connection using the gateway created in the previous step. This was created successfully as well.

 

 

 

Hello Mabel,

 

Thank you for your reply. I checked the reference provided (https://powerapps.microsoft.com/en-us/blog/support-for-sharepoint-on-premises/) and I was able to install/configure the On-Premises Data Gateway. Once I created the gateway I checked its status at web.powerapps.com under Gateways and it shows Live.

 

Gateway Live.jpg

 

 

 

 

 

 

 

 

 

 

 

 

Next I created a SharePoint on-premises connection using the gateway created in the previous step. This step was successfull as well.

SharePoint on-premises connection.jpg 

 

 

 

Next I tried to create a new PowerApp using SharePoint (Phone layout) template and I was redirected to choose a Connection. I selected the connection created in the previous step.

 

My SharePoint on-premises web application is configured on HTTPS only (only one secure binding in IIS).

 

Hello Mabel,

 

Thank you for your reply. I checked the reference provided (https://powerapps.microsoft.com/en-us/blog/support-for-sharepoint-on-premises/) and I was able to install/configure the On-Premises Data Gateway. Once I created the gateway I checked its status at web.powerapps.com under Gateways and it shows Live.

 

Gateway Live.jpg

 

 

 

 

 

 

 

 

 

 

 

 

Next I created a SharePoint on-premises connection using the gateway created in the previous step. This step was successfull as well.

SharePoint on-premises connection.jpg 

 

 

 

Next I tried to create a new PowerApp using SharePoint (Phone layout) template and I was redirected to choose a Connection. I selected the connection created in the previous step.

Use connection.fw.png

 

 

 

 

 

 

 

 

My SharePoint on-premises web application is configured on HTTPS only (only one secure binding in IIS).

I entered the URL for my SharePoint site starting with https://site_url.

When I click Go I get the following error:

 

 

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Top Kudoed Authors
Users online (52,959)